summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-11-09 07:23:01 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-11-10 21:56:35 +0100
commit7a83654c5af8fcf5b225e530a1947a807fedeb71 (patch)
treeae9b31cd5c776806148613b52ba80a9b8cf639c1 /app-admin
parentapp-misc/elasticsearch: drop old (diff)
downloadgentoo-7a83654c5af8fcf5b225e530a1947a807fedeb71.tar.gz
gentoo-7a83654c5af8fcf5b225e530a1947a807fedeb71.tar.bz2
gentoo-7a83654c5af8fcf5b225e530a1947a807fedeb71.zip
app-admin/logstash-bin: bump to 5.6.13
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/logstash-bin/Manifest1
-rw-r--r--app-admin/logstash-bin/logstash-bin-5.6.13.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/logstash-bin/Manifest b/app-admin/logstash-bin/Manifest
index 8cfce385f676..2fdc04c17cb8 100644
--- a/app-admin/logstash-bin/Manifest
+++ b/app-admin/logstash-bin/Manifest
@@ -1,4 +1,5 @@
DIST logstash-5.6.12.tar.gz 104371301 BLAKE2B be7a2c7df807ae9ab738c1ec7693e23bd4491e14cc866e50b2a4d6b58466ce94801ccc6684c7d297a2d89faba67ba10d61b50b57c439a8b3ba3fa3a0752b4529 SHA512 39411a92eac34160a9b38914c08165ba789c5d16f76b1823dd08305581b18a668fb680b60c6be50fd59b2bb79bf7f507b39b42cc71ac0f5b9c5be597048f32a5
+DIST logstash-5.6.13.tar.gz 104517136 BLAKE2B c4f0ba5f8e1624ef0493e553166a3c18aab9c4d73a661a5f91988627ec8470dc8a1b52461673e27169c8c10b33dfdeffeef96e70e1a8a04b7ee4a1e71a9afb68 SHA512 df12877b8d28ce9392f9d9ec9414205dd1f628a8e927c8b31f0ad3c3c7b11108509fe6b44119faa3f1bab393ea7be74a3a7c5b5b6b49d6ff5b54ce31fd024a04
DIST logstash-6.3.2.tar.gz 144211416 BLAKE2B 8471fd0a920b4ef06cd775ceaafde33e16e5d1898c89339f4a039262a7a6472d6cb8dd2017db8811d6a827395a5b1e7040d9759c8734de2ccd1fc7e615345813 SHA512 11507b9177aa6cd4172eb825e395571de71bae8b0e39d7f700fe27c7219b22bc2b9a493e39016eead2d54407dc5e5cc20a0c6e4453140d628cadea076453308f
DIST logstash-6.4.1.tar.gz 153922055 BLAKE2B 5a9c2852047e7a6a318eaa710d273cbfa172ae02c08a08b361a6f2bc48c5e46b3d7709652a51e3b0102fbf7c73ad179c18b6ed6a961bece53d009de065f13e5c SHA512 b496ed0746ee38a375a3efc5eb93677accb61c3482550a75cf9ad5e7b8e104eb8560bce79325ce85a27d22b664299edf1970452837189fcfa9310798c58825c1
DIST logstash-oss-6.3.2.tar.gz 144128583 BLAKE2B 99de9d375a06d132844ce63fa5d0e092bb05aedb93ff5e4a278ea75ca2fe68701afa3028af4f9c3e5b3b469e46faf4d6dc62d006e9dac3a9e9528ff94aa2dd47 SHA512 7fa97f0ca070677aaddc73ff900397ce4a45f4b02467917219acb3c414cf0cbf396b481f624d2ebc3f370b2e41120b3b103f6d080a9fafdce98b119eb8d27f5d
diff --git a/app-admin/logstash-bin/logstash-bin-5.6.13.ebuild b/app-admin/logstash-bin/logstash-bin-5.6.13.ebuild
new file mode 100644
index 000000000000..9692d38eba5b
--- /dev/null
+++ b/app-admin/logstash-bin/logstash-bin-5.6.13.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-pkg-2 user
+
+MY_PN="${PN%-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for managing events and logs"
+HOMEPAGE="https://www.elastic.co/products/logstash"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}.tar.gz"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
+
+RDEPEND="virtual/jre:1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN}
+}
+
+src_install() {
+ keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
+ keepdir "/var/lib/${MY_PN}"
+ keepdir "/var/log/${MY_PN}"
+
+ insinto "/usr/share/${MY_PN}"
+ newins "${FILESDIR}/agent.conf.sample" agent.conf
+
+ rm -v config/startup.options || die
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -rv config data || die
+
+ insinto "/opt/${MY_PN}"
+ doins -r .
+ fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"
+
+ newconfd "${FILESDIR}/${MY_PN}.confd-r1" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.initd-r1" "${MY_PN}"
+
+ insinto /usr/share/eselect/modules
+ doins "${FILESDIR}"/logstash-plugin.eselect
+}
+
+pkg_postinst() {
+ ewarn "The default pidfile directory has been changed from /run/logstash to /run."
+ ewarn "Please ensure any running logstash processes are shut down cleanly."
+ ewarn
+ ewarn "The default data directory has been moved from /opt/logstash/data to"
+ ewarn "/var/lib/logstash/data. Please check and move its contents as necessary."
+ ewarn
+ ewarn "Self installed plugins are removed during Logstash upgrades (Bug #622602)"
+ ewarn "Install the plugins via eselect module that will automatically re-install"
+ ewarn "all self installed plugins after Logstash upgrades."
+ elog
+ elog "Installing plugins:"
+ elog "eselect logstash-plugin install logstash-output-gelf"
+ elog
+
+ elog "Reinstalling self installed plugins (installed via eselect module):"
+ eselect logstash-plugin reinstall
+
+ elog
+ elog "Sample configuration:"
+ elog "${EROOT%/}/usr/share/${MY_PN}"
+}