summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-03 06:15:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-03 07:37:33 +0200
commit849f5622cad1130bf1ba83b980d081ebf2b7afab (patch)
tree0f9462b993a079e0cdac7d5cd2f673fd0207677b /app-admin
parentdev-python/boto3: Bump to 1.24.2 (diff)
downloadgentoo-849f5622cad1130bf1ba83b980d081ebf2b7afab.tar.gz
gentoo-849f5622cad1130bf1ba83b980d081ebf2b7afab.tar.bz2
gentoo-849f5622cad1130bf1ba83b980d081ebf2b7afab.zip
app-admin/awscli: Bump to 1.25.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index c9908c6d03ef..c3d5487e5d1a 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,3 +2,4 @@ DIST aws-cli-1.24.10.gh.tar.gz 2219050 BLAKE2B 9655429a65c81b5c6436f0bafb293243d
DIST aws-cli-1.24.5.gh.tar.gz 2215786 BLAKE2B db9077cfe3cf561109dea9ce1395f9d5bbe25b9dd28675e20d56c1fee3ad17e4befdce61cb81f217bb32d85b326ca4069f97482b9670f9653a850fd90fd135f7 SHA512 1cb4fcf37ccc6e7c3dfb211a9bc6687172f4052c6dae307e1a8451947078794973a3fd8382824ca2be650ee5b898b1f8d9bc27e2b403a2c51fea17b319bd366d
DIST aws-cli-1.25.0.gh.tar.gz 2219640 BLAKE2B 009863c9df07d01e5ddd849565124657bcead4dfac8a921247a1bcd4196593c93441f91fa1e2b4ee1908e5fd59b6559da98fa887083f70f110804a0e252f2c25 SHA512 305e16ea51ad0f689232b06dcf1964e0479b3c529631364688afc41e6441fc28ae934cd9959de493ea5734dacb81e01af27305609d6d3919656f8a55bebd4eac
DIST aws-cli-1.25.1.gh.tar.gz 2220206 BLAKE2B 574f0d3185911fdb72e15acb2922d15687bccb8551d7128618a7eba39ba5ed689591a1d3a51d75832834fc2511495cb84014bc733bbe49c997f8e92c2bd8dfde SHA512 f78cca5901fcf503ba4bfc3a403548878806f774677d5de1b86b7fcac97e020b3de7370ffb312db839130093319b1c0bf9e4aa9f5fb8f14da118957e2a71dd5e
+DIST aws-cli-1.25.2.gh.tar.gz 2220304 BLAKE2B 370137db21688db07a1367a1b82b906d5e7f16939fb9a10f8f8e60d986b68cd7cf3fcaca89baa097b351ce1552a9b35c143a5328972577cc08b2369a0ff35407 SHA512 4278be5b73865854a736ae447b729670310d557d019fe483376d8bb6317cc557f1567d8cbd77c4fc658d5593bdf8ddb2765696b144694c7df3d3447156ac14b0
diff --git a/app-admin/awscli/awscli-1.25.2.ebuild b/app-admin/awscli/awscli-1.25.2.ebuild
new file mode 100644
index 000000000000..4154af977ee6
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}