summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-10 13:44:41 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-10 13:44:59 -0600
commit85609c7e432aea09ac52f08ec0ed1644805d4758 (patch)
treebcbb333ed973fc0f83b86e10f7a167dfeac4c5bb /app-admin
parentdev-ruby/facter: bup (diff)
downloadgentoo-85609c7e432aea09ac52f08ec0ed1644805d4758.tar.gz
gentoo-85609c7e432aea09ac52f08ec0ed1644805d4758.tar.bz2
gentoo-85609c7e432aea09ac52f08ec0ed1644805d4758.zip
app-admin/mcollective: bup
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mcollective/Manifest1
-rw-r--r--app-admin/mcollective/mcollective-2.10.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/mcollective/Manifest b/app-admin/mcollective/Manifest
index 6776fb574e03..8ddf6d621030 100644
--- a/app-admin/mcollective/Manifest
+++ b/app-admin/mcollective/Manifest
@@ -1,3 +1,4 @@
DIST mcollective-2.10.0.tar.gz 1509016 SHA256 0a93c7c1c0f10d3e73ab3f255a542e170f7f9eed13ad56cc5cef883bac2e27b0 SHA512 021d52d299adba05c1960a242d7815b5fc3f763163c227d7b11b1bc48db40c147b7ab281a29f60c54f8049acfd8a3489ff837e8cf4a590e1450b2c53435124b1 WHIRLPOOL 67a39f6c82e81da1a90e8a2b02aa4101bcf821f833669715a701c075505501bc4706c68d1ed000d5a6c99c0258b16a2711a470f7145cc452c0780ca588c8ca7b
+DIST mcollective-2.10.1.tar.gz 1509293 SHA256 b47662b8ab3f150df6153f18c453bad049d8baf0cc8b5589436ae411258492fc SHA512 907bc4bb8527053f0813d19fd9a2fd19701af364d45385356772b09f3db50fd8c4d8e4e53ad9c3ad7c53c78bed52fcfec2354505272302c770c9cfea553309c5 WHIRLPOOL 4e283c42ae8f4161a47e95e1fc223d47fed3bc5308df09b3bd43a7b7d90e1927c2a6067faa872404e261f7e4597e900b7c994266587e8a73c53420d90614b6c6
DIST mcollective-2.8.8.tar.gz 1500476 SHA256 503b26cb0beeb505bf9cd2abbb8724c67bc743ffff4fbaddc321e2a4d663b133 SHA512 fad2a277bdcb06adb56e87f545c4b85a4b8039263e7230c7b386c561a04d6f3bf80923733e1087c8090b43da734d6b7efe02e52a757191c3cb3ecab50cc97bb6 WHIRLPOOL 3e7a52b1ce3b705ed6f705067a4ab900a2faa226d19a36f106e2c2c1e4c4fc3e631630c04012ca456f0230f8fcb47dd5bd97f1d2e849af6edde67fac129301d4
DIST mcollective-2.9.1.tar.gz 1504607 SHA256 89bc9fbd72846b22220074a57d19bbfac56473649078fc3ac8182cc728159249 SHA512 29fedacb61084e1952afd3b9deb302abde3e763d13630d85dc70f78b0853f5b353fb44ccbd00e48e5864d04bf2c7568d7cbe21b06af31e1da72e52aeef3c04cf WHIRLPOOL 8affee96fa344d12b34b5a4e120029ab315133df6fd6cd456d840ab608ceb2027b9411a6a1a74bc5b9d0b029968255a926de888b7a2a1183d1c7aed195f65f7a
diff --git a/app-admin/mcollective/mcollective-2.10.1.ebuild b/app-admin/mcollective/mcollective-2.10.1.ebuild
new file mode 100644
index 000000000000..2f791599c269
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.10.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="http://marionette-collective.org/"
+SRC_URI="https://github.com/puppetlabs/marionette-collective/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/all/marionette-collective-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ cd "marionette-collective-${PV}"
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ use client && dosbin bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] http://activemq.apache.org/"
+ einfo "[2] https://code.google.com/p/mcollective/wiki/GettingStarted"
+}