summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-04-01 00:03:53 -0700
committerZac Medico <zmedico@gentoo.org>2024-04-01 00:04:26 -0700
commit85d9e9c1254cb53ea9f697a13e4bf8bd36a562d1 (patch)
tree56c75b4f68d9988c264edbe10f1e8f422edc553d /app-admin
parentsys-apps/kexec-tools: Add patch for build error with binutils 2.42 (diff)
downloadgentoo-85d9e9c1254cb53ea9f697a13e4bf8bd36a562d1.tar.gz
gentoo-85d9e9c1254cb53ea9f697a13e4bf8bd36a562d1.tar.bz2
gentoo-85d9e9c1254cb53ea9f697a13e4bf8bd36a562d1.zip
app-admin/consul-template: add 0.37.4
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/consul-template/Manifest2
-rw-r--r--app-admin/consul-template/consul-template-0.37.4.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/app-admin/consul-template/Manifest b/app-admin/consul-template/Manifest
index 1478714eb232..97a28e9e68d8 100644
--- a/app-admin/consul-template/Manifest
+++ b/app-admin/consul-template/Manifest
@@ -1,2 +1,4 @@
DIST consul-template-0.29.4-deps.tar.xz 59446648 BLAKE2B 9ccd689f38eff50ad448a4226de918920c7acca9eb1e23d4e30f9999afc124224bb8f123b3dff4a1d433ea683ed523cd604a41472f50cb1919483040fc18c848 SHA512 3c60d88fdb82744f250cf02be3b3423f74360f18a43f4c4204ee97f73c370b878ecdbd5a300f96b74ffd9c7cde66f6c8b974392f7acc07a113b85ab6f1b6d8e9
DIST consul-template-0.29.5.tar.gz 262722 BLAKE2B 1e3ddf259d76cf487872cebbe8c8b5bb313b89d073b26496340d39cc55c4e56ec531cbefec4bc1c0dd5c8bb3bd707c9bebfd15011e421badf12ea59a5bbbdbe3 SHA512 f753c2ec7f6c97ac73b34820b40568b5b16a3b8d4bebc7390905614a96744e8d4afd4a63b8b911989ba084ea91d85a21e3283d67a36bf65a685aa63154361a14
+DIST consul-template-0.37.4-deps.tar.xz 1548760 BLAKE2B 34a4e7926f41578071e60c715c534a8a50c49db3a78b06ae6ee49ed1a1c857faea753f27921cb6345bbc94f44ab81da58d3ffd1d27a0e29220bd2631bb35b58a SHA512 e28e29034407a5fbf78f9872b2cd85c0d6414cb5ec3c4b023b080c227583ae34ead6ab5b98c6ff4e1d278d9af137e895cedc79def10017d073f2b99561f1d483
+DIST consul-template-0.37.4.tar.gz 288565 BLAKE2B 69fc82a482c7fce4201621ee43aca689b328be4e34bb99e1cd552ba844787744a97fb64364adc7d9a180fd424d30881deaed45077851bc10fa037799ea99d189 SHA512 e36a5e444801c8700577df28fb3fbc7398b825d8f549d620c07445d86099a7597d0e95d56ce24daedd44eb573cc33e40dd1bb1e7a6def2c2a1788133bb811c38
diff --git a/app-admin/consul-template/consul-template-0.37.4.ebuild b/app-admin/consul-template/consul-template-0.37.4.ebuild
new file mode 100644
index 000000000000..adf2f99b89be
--- /dev/null
+++ b/app-admin/consul-template/consul-template-0.37.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="Generic template rendering and notifications with Consul"
+HOMEPAGE="https://github.com/hashicorp/consul-template"
+SRC_URI="https://github.com/hashicorp/consul-template/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="MPL-2.0"
+LICENSE+=" Apache-2.0 BSD BSD-2 ISC MIT WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="
+ acct-group/consul-template
+ acct-user/consul-template"
+
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+# TODO: debug test failures
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ # remove -s and -w from the linker flags
+ sed \
+ -e '/-s \\/d' \
+ -e '/-w \\/d' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake GOBIN="${S}"/bin dev
+}
+
+src_test() {
+ emake GOBIN="${S}"/bin test
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc CHANGELOG.md README.md
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ keepdir /etc/${PN}.d
+
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}