summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-07 21:49:14 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-07 21:56:14 -0500
commit85fed5462e94009ce3a4b7d31dec58762b1c58f1 (patch)
tree28bde11c501a3f1951f34ce0bc790111b27f6e58 /app-admin
parentmedia-sound/spotify: 1.1.56 bump (diff)
downloadgentoo-85fed5462e94009ce3a4b7d31dec58762b1c58f1.tar.gz
gentoo-85fed5462e94009ce3a4b7d31dec58762b1c58f1.tar.bz2
gentoo-85fed5462e94009ce3a4b7d31dec58762b1c58f1.zip
app-admin/rasdaemon: 0.6.7 bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/rasdaemon/Manifest1
-rw-r--r--app-admin/rasdaemon/rasdaemon-0.6.7.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-admin/rasdaemon/Manifest b/app-admin/rasdaemon/Manifest
index e0d3a767a2b6..6782f8dd3bc9 100644
--- a/app-admin/rasdaemon/Manifest
+++ b/app-admin/rasdaemon/Manifest
@@ -1 +1,2 @@
DIST rasdaemon-0.6.6.tar.bz2 404681 BLAKE2B 4314cd064b255df1cb1a148914c856d074fda1fc2d63e0554cbf0b78799c4252afdd4e827390729e191ff2ed9f719f6610487e85dd52af2b02694fb17740df05 SHA512 481ecd624ab5521d60ee7c613ee05d1d19b85e914b92eae84d18cb2e6dc788981213d49a6316cf575517b6e180f46c66c65804e4feb518bdd84bc21cd2970e08
+DIST rasdaemon-0.6.7.tar.bz2 422473 BLAKE2B 32a95ed9ca217fb69b197f88fa296bf0d3b4230a1ae11c60582911ff84abbe8b9a67b318774b8c4b765dbedbd4458eb220ca3b8ff4c9d065eb893a9a6a9916c5 SHA512 15beae5d4964c49b7b7f9e731948b5def9622fba5d7d17ce52a282d7834d256366cdf3cf427b82b2a6a8fd0c99f202f545000bdb06064fbae7ae0296aef0946c
diff --git a/app-admin/rasdaemon/rasdaemon-0.6.7.ebuild b/app-admin/rasdaemon/rasdaemon-0.6.7.ebuild
new file mode 100644
index 000000000000..c5aa842b5d02
--- /dev/null
+++ b/app-admin/rasdaemon/rasdaemon-0.6.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="Reliability, Availability and Serviceability logging tool"
+HOMEPAGE="http://www.infradead.org/~mchehab/rasdaemon/"
+SRC_URI="http://www.infradead.org/~mchehab/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sqlite"
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ sys-devel/gettext
+ sys-apps/dmidecode
+ sqlite? (
+ dev-db/sqlite
+ dev-perl/DBD-SQLite
+ )
+"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ local CONFIG_CHECK="~ACPI_EXTLOG"
+ check_extra_config
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable sqlite sqlite3)
+ --enable-abrt-report
+ --enable-aer
+ --enable-arm
+ --enable-extlog
+ --enable-hisi-ns-decode
+ --enable-mce
+ --enable-non-standard
+ --enable-devlink
+ --enable-diskerror
+ --enable-memory-ce-pfa
+ --includedir="/usr/include/${PN}"
+ --localstatedir=/var
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ keepdir "/var/lib/${PN}"
+
+ systemd_dounit misc/*.service
+
+ newinitd "${FILESDIR}/rasdaemon.openrc-r2" rasdaemon
+ newinitd "${FILESDIR}/ras-mc-ctl.openrc-r1" ras-mc-ctl
+ newconfd "${FILESDIR}"/rasdaemon.confd rasdaemon
+}