summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2017-11-25 03:11:35 +0000
committerAmy Liffey <amynka@gentoo.org>2017-11-25 14:22:29 +0100
commit8d3c1fdb6f0e9e5ac051519d17e5fc30d701d460 (patch)
tree5925c6dbb306c579ae2de5dfdec61bf3f3281087 /app-admin
parentwww-apps/kibana-bin: bump to 6.0.0 (diff)
downloadgentoo-8d3c1fdb6f0e9e5ac051519d17e5fc30d701d460.tar.gz
gentoo-8d3c1fdb6f0e9e5ac051519d17e5fc30d701d460.tar.bz2
gentoo-8d3c1fdb6f0e9e5ac051519d17e5fc30d701d460.zip
app-admin/logstash-bin: bump to 6.0.0
Closes:#6288
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/logstash-bin/Manifest1
-rw-r--r--app-admin/logstash-bin/logstash-bin-6.0.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/logstash-bin/Manifest b/app-admin/logstash-bin/Manifest
index 7105be5c0439..ce84a7e42071 100644
--- a/app-admin/logstash-bin/Manifest
+++ b/app-admin/logstash-bin/Manifest
@@ -1,2 +1,3 @@
DIST logstash-5.5.3.zip 99551442 SHA256 f81ff55feb21ff4edd4283938ac8362c2906d98f9427d8660dab8465e08f0da9 SHA512 a4328ad0b8192b7c5aaed155d608d9db6adeaefd640e461ef4467daa1a28a2ae25d6b2b1adcf47c5dd82b66fc1adbf8ba5f3eabcf7e69dd8719a5860795877aa WHIRLPOOL d3482df4a7729f6b34973816e39315c69254a641e9811131d7d5e12ede54003a326c5773e799ee471dda01a6113762919ea81ab56ede62d29221f63ed5a7f8c7
DIST logstash-5.6.4.zip 109819435 SHA256 8809cee0b4199eafd5e3094243929d24b0d22c9d2fcaa473cb7031207d079ca8 SHA512 5382671758d905bbd89f9e05eff9ffcf4a3bbc4fca6f06844647c31df3f50198c297daa0151915c9ef1f0cd741ccb9fb12a7fa13cdc429463d92783c92624717 WHIRLPOOL e1d4cea766025564cb12720528ce0819b3787fb4ffc1901593786d79195ea1584834b70d0406d4b39dfcc236c9239af9e63b37e497c9fc7a79899a4a5f62b429
+DIST logstash-6.0.0.zip 118915764 BLAKE2B fd99a2d73c0f7bc381154f197353cb8a5f55f8c278b8381207b3bbeac13dd7850ae4b994dbcc582324b11e7a9bfa6807bcaeebf5506b5234bc6ba0ad62009182 SHA512 9d830f5a88e51b5076af13cc2909fd42c7a75de9466fdd0e7379dff20e7f6d6bfd97b6005278222fb3ab020aa98a572023fc36a7f7cde2eaa4d9a1745f3c82b4
diff --git a/app-admin/logstash-bin/logstash-bin-6.0.0.ebuild b/app-admin/logstash-bin/logstash-bin-6.0.0.ebuild
new file mode 100644
index 000000000000..f5c2a9c0a255
--- /dev/null
+++ b/app-admin/logstash-bin/logstash-bin-6.0.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-pkg-2 user
+
+MY_PN="${PN%-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for managing events and logs"
+HOMEPAGE="https://www.elastic.co/products/logstash"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}.zip"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
+
+RDEPEND="virtual/jre:1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN}
+}
+
+src_install() {
+ keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
+ keepdir "/var/lib/${MY_PN}"
+ keepdir "/var/log/${MY_PN}"
+
+ insinto "/usr/share/${MY_PN}"
+ newins "${FILESDIR}/agent.conf.sample" agent.conf
+
+ rm -v config/startup.options || die
+ insinto /etc/${MY_PN}
+ doins config/*
+ rm -rv config data || die
+
+ insinto "/opt/${MY_PN}"
+ doins -r .
+ fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"
+
+ newconfd "${FILESDIR}/${MY_PN}.confd-r1" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.initd-r1" "${MY_PN}"
+
+ insinto /usr/share/eselect/modules
+ doins "${FILESDIR}"/logstash-plugin.eselect
+}
+
+pkg_postinst() {
+ ewarn "The default pidfile directory has been changed from /run/logstash to /run."
+ ewarn "Please ensure any running logstash processes are shut down cleanly."
+ ewarn
+ ewarn "The default data directory has been moved from /opt/logstash/data to"
+ ewarn "/var/lib/logstash/data. Please check and move its contents as necessary."
+ ewarn
+ ewarn "Self installed plugins are removed during Logstash upgrades (Bug #622602)"
+ ewarn "Install the plugins via eselect module that will automatically re-install"
+ ewarn "all self installed plugins after Logstash upgrades."
+ einfo
+ einfo "Installing plugins:"
+ einfo "eselect logstash-plugin install logstash-output-gelf"
+ einfo
+
+ einfo "Reinstalling self installed plugins (installed via eselect module):"
+ eselect logstash-plugin reinstall
+
+ einfo
+ einfo "Sample configuration:"
+ einfo "${EROOT%/}/usr/share/${MY_PN}"
+}