summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-09 06:03:33 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-09 06:03:33 +0200
commit91a8186552671a1a3b5a6581856a8ecda8f9c7a5 (patch)
tree95fa2a9af5880b7d5a5f7d0e107b1ea2bf4091e8 /app-admin
parentdev-ruby/rgen: amd64 stable (diff)
downloadgentoo-91a8186552671a1a3b5a6581856a8ecda8f9c7a5.tar.gz
gentoo-91a8186552671a1a3b5a6581856a8ecda8f9c7a5.tar.bz2
gentoo-91a8186552671a1a3b5a6581856a8ecda8f9c7a5.zip
app-admin/puppet-lint: add 2.3.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-lint/Manifest1
-rw-r--r--app-admin/puppet-lint/puppet-lint-2.3.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/Manifest b/app-admin/puppet-lint/Manifest
index 1430ba0f968b..034163e61a9c 100644
--- a/app-admin/puppet-lint/Manifest
+++ b/app-admin/puppet-lint/Manifest
@@ -1,2 +1,3 @@
DIST puppet-lint-2.3.3.gem 84992 BLAKE2B 57b6d6332b7d26daf193ba983ff1e5d560cf4f902f1b476de3b1f7254755851397685d7b435dd7365f81e1427d91ca47ffa889a9d87a14e1c4720e44aa2b7996 SHA512 9203e8d29cb4a5c5abf8279598599db4a9063d33d7b7d6c76f8ebf09c3ba539f6035083b5438bae2b0fda1d16880ffcb69a2776ebce7f54bc1a1430c2ceb0d68
DIST puppet-lint-2.3.5.gem 86528 BLAKE2B 7455c729cb0512cb26838439c854c70d2581f2102594ac60d76a34f9839b0bb7dbab65beb87369419dc0e66583bfac1ad9f22d65ee3ee9bf35aa3c37e8f0d1b9 SHA512 5e1978c5438869c12c2151e76fe6cea12c447d9f59f1fbbc90fb80e61c7ff9c220be85f70cf95dec2380cd35205ffec0473cc7eda0db21b94a30b533d4214707
+DIST puppet-lint-2.3.6.gem 87552 BLAKE2B 0a2f4b9c2ef76c06bc4fb6eb0f737af406bf3949e7c9001685c6522714b550c0f2c5680d5d39f5d3994496a497664e912eadc44bdb7aa4c27635d23b36a90776 SHA512 d162307e66bb5f1dd923f2f9fab55de7b4c5fad6264d7a1bae8df20bd45c5a786b66d9f5b3bd235230fea959c67242462e711212f65807040048f4c0be7122b9
diff --git a/app-admin/puppet-lint/puppet-lint-2.3.6.ebuild b/app-admin/puppet-lint/puppet-lint-2.3.6.ebuild
new file mode 100644
index 000000000000..c86bd234ccc4
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-2.3.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit eutils ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="http://puppet-lint.com/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1
+ dev-ruby/rspec-json_expectations )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}