summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-02-23 12:12:57 -0500
committerCraig Andrews <candrews@gentoo.org>2018-02-23 12:13:25 -0500
commit98fa712f5f781b44833bb6cdda9f362a1627a26d (patch)
tree047380bc3f58a7d318bd9d9ffc4032336453e21d /app-admin
parentdev-db/psqlodbc: Clean old (diff)
downloadgentoo-98fa712f5f781b44833bb6cdda9f362a1627a26d.tar.gz
gentoo-98fa712f5f781b44833bb6cdda9f362a1627a26d.tar.bz2
gentoo-98fa712f5f781b44833bb6cdda9f362a1627a26d.zip
app-admin/needrestart: 3.0 version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/needrestart/Manifest1
-rw-r--r--app-admin/needrestart/needrestart-3.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/needrestart/Manifest b/app-admin/needrestart/Manifest
index f79195694347..5b3616756cef 100644
--- a/app-admin/needrestart/Manifest
+++ b/app-admin/needrestart/Manifest
@@ -1 +1,2 @@
DIST needrestart-2.11.tar.gz 52156 BLAKE2B fb3ffbf6f7876625ad0b7db4feb629c80f0798b7b117f5c94058533e8ed53e695fca5de76670a184245e23720886c79b97c3cfdcc5e9400c1e6988fdb2f64459 SHA512 e987ebafe77aba6920645088fa12e609b52f55edfd545ede1c0a93ee1d6b91ed3ea84cb8db69cd067aaabe8ba973b366da61301b5527ec176a29e3ba30605311
+DIST needrestart-3.0.tar.gz 58437 BLAKE2B 6f3b79f793dab85af2a68f3796926b958c077b16c357969943db867dead470cef20aadb076a12a0e3161efc64c82cd1df7f6cdbc70f73cce563a11dec472f69a SHA512 6b653e29b10e497563e67102e11833f7c97d2bde697a99130ff89d5fcd2e616fec279328656f44ccdbb62a2c533bf10827b035efad7785ef5d0556c7f37e625f
diff --git a/app-admin/needrestart/needrestart-3.0.ebuild b/app-admin/needrestart/needrestart-3.0.ebuild
new file mode 100644
index 000000000000..062247caf71e
--- /dev/null
+++ b/app-admin/needrestart/needrestart-3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/liske/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Restart daemons after library updates"
+HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
+
+SLOT="0"
+LICENSE="GPL-2+"
+
+RDEPEND="
+ >=sys-apps/sed-4.2.2
+ dev-lang/perl:=
+ dev-perl/libintl-perl
+ dev-perl/Module-Find
+ dev-perl/Module-ScanDeps
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/TermReadKey
+ sys-apps/init-system-helpers
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_install() {
+ default
+ doman man/*.1
+ dodoc -r ex
+}