summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2018-10-24 13:36:12 -0700
committerPatrick McLean <chutzpah@gentoo.org>2018-10-24 15:59:00 -0700
commit9fb2ad3eddd80634ff623c9b9d6ae3a9499e55a6 (patch)
tree3d534904ec6afc1e80693172372378dbea9eaf8d /app-admin
parentapp-admin/salt: Version bump to 2016.11.10 (diff)
downloadgentoo-9fb2ad3eddd80634ff623c9b9d6ae3a9499e55a6.tar.gz
gentoo-9fb2ad3eddd80634ff623c9b9d6ae3a9499e55a6.tar.bz2
gentoo-9fb2ad3eddd80634ff623c9b9d6ae3a9499e55a6.zip
app-admin/salt: Version bump to 2017.7.8
Signed-off-by: Patrick McLean <chutzpah@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/salt/Manifest2
-rw-r--r--app-admin/salt/files/salt-2017.7.8-tests.patch (renamed from app-admin/salt/files/salt-2017.7.3-tests.patch)24
-rw-r--r--app-admin/salt/salt-2017.7.8.ebuild (renamed from app-admin/salt/salt-2017.7.7.ebuild)6
3 files changed, 18 insertions, 14 deletions
diff --git a/app-admin/salt/Manifest b/app-admin/salt/Manifest
index 011dcc86542b..07da69d6b1be 100644
--- a/app-admin/salt/Manifest
+++ b/app-admin/salt/Manifest
@@ -1,3 +1,3 @@
DIST salt-2016.11.10.tar.gz 10058200 BLAKE2B 4b6a42f6bf56421bc19458686ec23a1f945ceeb68b4ce7059fde036ba98d677fc8b61cb0f0c6ab249304b2f07d1b0250f6b91e7c443e12868649bf88f4d44d43 SHA512 e767e2c4c20e3a49a748b2699e4c640610280c0ba1c5955d94daffc7c36991ee632f02a50e338c65b35da146e234c36cc732214174b9bc5cbd62316b9ee40c28
-DIST salt-2017.7.7.tar.gz 11131480 BLAKE2B ea01c8894433cf96697c830d58184bfefca52dcd1be9b1c398270acc229886eeb41edf83d1498fc500f23209fc4e56ba8471da88383bd4c1a9338262423477fb SHA512 01cba364e2dcb5021b2b3b738462645c84332bbf31c0fa82f017fc583a097dccde308fd86be54d2b429921f34c89a4a40b942385c3bc139eb11753d155664063
+DIST salt-2017.7.8.tar.gz 12060430 BLAKE2B b2dde1b6f43bbb9b9db29b70dfd57591ae0e490e35ec7f4895b68b444ff77f9e997321d73697f791d345756abf451f11891b5f78a97c537c35dfe8bd24c43bbc SHA512 1e5123ee3dc194a33cf5da1e68a0419230b2b4eea26e7f66bf2d64754f0dbef9012abfbd498015f6b675725e580d72abf13c151b106639597337498b1fd42238
DIST salt-2018.3.2.tar.gz 12996445 BLAKE2B 8411fb0891e23ce8e35157662a0a45c0c5b13b62f3fd21cc4bbe5152f923a98b27cb5bee4fb8cb3e6ec5c9daed1afa27baf4b570b94f9f40eddc0891f72829e9 SHA512 142ebe13638d7e6dd0aecc9f0325002d30e115fe8688f5f74cbeb7ff21020327d65ded0dcd845e55362b97568b696887fa22243d66d5eadef65f97152d4775d3
diff --git a/app-admin/salt/files/salt-2017.7.3-tests.patch b/app-admin/salt/files/salt-2017.7.8-tests.patch
index 9399bf873349..e428108c4614 100644
--- a/app-admin/salt/files/salt-2017.7.3-tests.patch
+++ b/app-admin/salt/files/salt-2017.7.8-tests.patch
@@ -1,25 +1,29 @@
diff --git a/tests/unit/fileserver/test_roots.py b/tests/unit/fileserver/test_roots.py
-index cc9c8dbce9..a50a240c25 100644
+index 23f3b26874..bf0b55c385 100644
--- a/tests/unit/fileserver/test_roots.py
+++ b/tests/unit/fileserver/test_roots.py
-@@ -164,12 +164,6 @@ class RootsTest(TestCase, AdaptedConfigurationTestCaseMixin, LoaderModuleMockMix
+@@ -173,16 +173,6 @@ class RootsTest(TestCase, AdaptedConfigurationTestCaseMixin, LoaderModuleMockMix
ret = roots.dir_list({'saltenv': 'base'})
self.assertIn('empty_dir', ret)
- def test_symlink_list(self):
-- if self.test_symlink_list_file_roots:
-- self.opts['file_roots'] = self.test_symlink_list_file_roots
-- ret = roots.symlink_list({'saltenv': 'base'})
-- self.assertDictEqual(ret, {'dest_sym': 'source_sym'})
--
+- orig_file_roots = self.opts['file_roots']
+- try:
+- if self.test_symlink_list_file_roots:
+- self.opts['file_roots'] = self.test_symlink_list_file_roots
+- ret = roots.symlink_list({'saltenv': 'base'})
+- self.assertDictEqual(ret, {'dest_sym': 'source_sym'})
+- finally:
+- if self.test_symlink_list_file_roots:
+- self.opts['file_roots'] = orig_file_roots
- class RootsLimitTraversalTest(TestCase, AdaptedConfigurationTestCaseMixin):
+ class RootsLimitTraversalTest(TestCase, AdaptedConfigurationTestCaseMixin):
diff --git a/tests/unit/modules/test_inspect_collector.py b/tests/unit/modules/test_inspect_collector.py
-index 0d37519a9e..c18be8d592 100644
+index c2a86d9e5e..421cab9b52 100644
--- a/tests/unit/modules/test_inspect_collector.py
+++ b/tests/unit/modules/test_inspect_collector.py
-@@ -59,44 +59,6 @@ class InspectorCollectorTestCase(TestCase):
+@@ -61,44 +61,6 @@ class InspectorCollectorTestCase(TestCase):
inspector.pidfile,
os.sep + os.sep.join(['foo', 'pid', 'bar.pid']))
diff --git a/app-admin/salt/salt-2017.7.7.ebuild b/app-admin/salt/salt-2017.7.8.ebuild
index bb76353c1a4d..af04cbe98e20 100644
--- a/app-admin/salt/salt-2017.7.7.ebuild
+++ b/app-admin/salt/salt-2017.7.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,7 +17,7 @@ if [[ ${PV} == 9999* ]]; then
KEYWORDS=""
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~x86 ~amd64"
+ KEYWORDS="~amd64 ~x86"
fi
LICENSE="Apache-2.0"
@@ -94,7 +94,7 @@ RESTRICT="x86? ( test )"
PATCHES=(
"${FILESDIR}/${PN}-2017.7.0-dont-realpath-tmpdir.patch"
- "${FILESDIR}/${PN}-2017.7.3-tests.patch"
+ "${FILESDIR}/${PN}-2017.7.8-tests.patch"
)
python_prepare() {