summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:54:08 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:43 +0100
commitd1c6e4ae9423487be7ffcbc7e8261789ec897033 (patch)
treeb8620b6e4a38066f0d738ba04520730842d5f287 /app-admin
parentapp-admin/puppet-agent: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-d1c6e4ae9423487be7ffcbc7e8261789ec897033.tar.gz
gentoo-d1c6e4ae9423487be7ffcbc7e8261789ec897033.tar.bz2
gentoo-d1c6e4ae9423487be7ffcbc7e8261789ec897033.zip
app-admin/puppetdb: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppetdb/puppetdb-7.4.1.ebuild2
-rw-r--r--app-admin/puppetdb/puppetdb-7.5.0.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/app-admin/puppetdb/puppetdb-7.4.1.ebuild b/app-admin/puppetdb/puppetdb-7.4.1.ebuild
index 06b2986213b8..d1028bca1724 100644
--- a/app-admin/puppetdb/puppetdb-7.4.1.ebuild
+++ b/app-admin/puppetdb/puppetdb-7.4.1.ebuild
@@ -81,6 +81,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process puppetdb.conf
+
elog "to install please run '/opt/puppetlabs/server/bin/puppetdb ssl-setup'"
elog
elog "to upgrade please run '/opt/puppetlabs/server/bin/puppetdb config-migration'"
diff --git a/app-admin/puppetdb/puppetdb-7.5.0.ebuild b/app-admin/puppetdb/puppetdb-7.5.0.ebuild
index 78bd75a0264e..d3f27c98cbb9 100644
--- a/app-admin/puppetdb/puppetdb-7.5.0.ebuild
+++ b/app-admin/puppetdb/puppetdb-7.5.0.ebuild
@@ -81,6 +81,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process puppetdb.conf
+
elog "to install please run '/opt/puppetlabs/server/bin/puppetdb ssl-setup'"
elog
elog "to upgrade please run '/opt/puppetlabs/server/bin/puppetdb config-migration'"