summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-30 05:38:31 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-30 06:23:18 +0100
commitd1cc5a60f2ed03c23bffae0de46fa742756222e2 (patch)
treef23ae431a3c69c82458ce7e5b4908f4023e5f1df /app-admin
parentdev-python/boto3: Bump to 1.34.74 (diff)
downloadgentoo-d1cc5a60f2ed03c23bffae0de46fa742756222e2.tar.gz
gentoo-d1cc5a60f2ed03c23bffae0de46fa742756222e2.tar.bz2
gentoo-d1cc5a60f2ed03c23bffae0de46fa742756222e2.zip
app-admin/awscli: Bump to 1.32.74
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.74.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 6dd809bd2077..b3c28f605dd5 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.32.70.gh.tar.gz 2675950 BLAKE2B bbe8b0a7c2c603e977f19922bd26fc991
DIST aws-cli-1.32.71.gh.tar.gz 2676392 BLAKE2B d20c5ac461e1fa9547b381f1f9040943a59c4fd9bf53dfcf4359c0f5c3bb08d28304f7da057e3196a927882768a333b37a1729d6fb604a8dd07361bedf93b1e0 SHA512 a197ef31df0ef3c6b229645a5e13ba83e8dd92f89a25388615c82fe63667e1bc86936e9f0591ea709200b6218720b3510b262b46df4b61bc2210aefe46928cb9
DIST aws-cli-1.32.72.gh.tar.gz 2676512 BLAKE2B 1ee9efca27bcd975dc641183a6d2dbb0519fa5c84608eb3918a3ccee864794c0d5bf237f905ed89e52c4a2079d484ba1c4f414af8088170c0b69efd3941a73a6 SHA512 a2a0bcdfb45971d96706a4adaeb642a09dcba33c4c261b6f445475a266c6667bdcaaf91c6acb4a9d2a038b8551ef9f59e009bdb78eab8ce3cc661dccbf2f399b
DIST aws-cli-1.32.73.gh.tar.gz 2676829 BLAKE2B 61e242131ca24d83820d029fcde7377fa8ff0b6becd4b60f29da0762e4e2a9eed4af86d66eb78cf3c9a39f4d09afc977460ba2b658bc52288d709543fb4d41f5 SHA512 2b3857a7a4ca18b684c4f491cb8922b84215690e7a5bf1dc278901b4a1bd863e64e5e809c10b133d8dab4b8cf6fb39dcd152f603a9dfb177967375cd69e5c503
+DIST aws-cli-1.32.74.gh.tar.gz 2682208 BLAKE2B aba8be6e597a6d07197bd06d51f167f7a2dbed317c630572585cd006f6edfceac054726a20afe20faf6de381cbb75e352a7d6ab9e232b6e669fd59ca5888e122 SHA512 2f19b7c383c91528f15b93b00df285bdf32685c08e41e4f8f3a62cbbd5cff2615ca98c5eb925a5a2a2d13b452a0a08658749f4f7a48045a537ee7ec7e23cd663
diff --git a/app-admin/awscli/awscli-1.32.74.ebuild b/app-admin/awscli/awscli-1.32.74.ebuild
new file mode 100644
index 000000000000..4a677affdbc4
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.74.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}