summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-09 07:08:07 +0200
committerHans de Graaff <graaff@gentoo.org>2019-10-09 07:47:37 +0200
commitd1d4002d494a55532f7bd6417c478bf0314e7781 (patch)
tree76489fec3d7b1932244b7e86e33aaf7b3f3f14a8 /app-admin
parentmedia-libs/assimp: Patched findassimp cmake script (diff)
downloadgentoo-d1d4002d494a55532f7bd6417c478bf0314e7781.tar.gz
gentoo-d1d4002d494a55532f7bd6417c478bf0314e7781.tar.bz2
gentoo-d1d4002d494a55532f7bd6417c478bf0314e7781.zip
app-admin/puppet-lint: add 2.4.1
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-lint/Manifest1
-rw-r--r--app-admin/puppet-lint/puppet-lint-2.4.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/Manifest b/app-admin/puppet-lint/Manifest
index a4735e6acf36..3071336f38e6 100644
--- a/app-admin/puppet-lint/Manifest
+++ b/app-admin/puppet-lint/Manifest
@@ -1 +1,2 @@
DIST puppet-lint-2.3.6.gem 87552 BLAKE2B 0a2f4b9c2ef76c06bc4fb6eb0f737af406bf3949e7c9001685c6522714b550c0f2c5680d5d39f5d3994496a497664e912eadc44bdb7aa4c27635d23b36a90776 SHA512 d162307e66bb5f1dd923f2f9fab55de7b4c5fad6264d7a1bae8df20bd45c5a786b66d9f5b3bd235230fea959c67242462e711212f65807040048f4c0be7122b9
+DIST puppet-lint-2.4.1.gem 92160 BLAKE2B 5bcdf14cad8cbf90e69c6afaa6935768db3cd9023175a8d5632951c7ff0d5b91362988c0e667c0f852eae705920a6a570f582db394b89436f61eda50f314dc9b SHA512 39d872350ab9ad276c346a7020269f246889dfb00eef020f93a5b53a93e4ae8fd5cf307ac057d6129edf52974ea71af0abcf422e9e0be0ba570d029ffa7011bc
diff --git a/app-admin/puppet-lint/puppet-lint-2.4.1.ebuild b/app-admin/puppet-lint/puppet-lint-2.4.1.ebuild
new file mode 100644
index 000000000000..738798f64b2f
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-2.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit eutils ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="http://puppet-lint.com/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1
+ dev-ruby/rspec-json_expectations )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}