summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2017-02-08 09:17:35 +0100
committerUltrabug <ultrabug@gentoo.org>2017-02-08 09:19:04 +0100
commitd42976363974e63c8cef1acef93daf37337774cb (patch)
treefed521782aae6c8b5cf66aac661af77af3a7ea2c /app-admin
parentapp-crypt/aespipe: Fix typo in metadata.xml. (diff)
downloadgentoo-d42976363974e63c8cef1acef93daf37337774cb.tar.gz
gentoo-d42976363974e63c8cef1acef93daf37337774cb.tar.bz2
gentoo-d42976363974e63c8cef1acef93daf37337774cb.zip
app-admin/mongo-tools: version bump, fix libpcap dep #607626
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.2.12.ebuild1
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.4.2.ebuild59
3 files changed, 61 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index 79fcee6f0747..45f3487059e6 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -3,3 +3,4 @@ DIST mongo-tools-3.0.14.tar.gz 2413148 SHA256 5a3f706827a9567fc98e2b64a33a2071c6
DIST mongo-tools-3.2.11.tar.gz 2712014 SHA256 992e9fb94df6bed49e68684afee096f1193dc9cfca8ce8bcc4c912996bba365c SHA512 a6e2dd8dd567f04205e57be2983f5f0ddf2c4aca915f5ffaa777d17b94f62e0f106eb9bad93213d25f60c3949d47f4d91cdf767744e8094278e8ecf3546dfae5 WHIRLPOOL 6d75a9b0e6cd4271f8c6571dd280adafc7ff1bb60f973a037c78b39df0981d6c35f1a38309a8d96300f45053054c4454f22ce75aea2d62da6db06a2b1adcf90d
DIST mongo-tools-3.2.12.tar.gz 2712079 SHA256 cda5e869b9233d591e91cac0b4c709a2e71dcabd9ac6bcc8b33d906ce3b13afd SHA512 66f7beb85a83ad6a217e65bba97ace6ad0bf84688f40e598e5fb1cf4bbe481b4069e1247d6829f8d06c8230d33c3e0c8bd8465a975576cad584065c361b6fb72 WHIRLPOOL 46123dc3c97fdf20ff94ac373e774932bd30aca677047fe3366653aaab269bf6d7e59cb420cf1e5716558fa959cb3649ee359cc27932bac276e6d24d2eea43b1
DIST mongo-tools-3.4.1.tar.gz 4700560 SHA256 283d729442fca7a331ca475e234b0880ec7c4339597e0a8e271ca7e153b45439 SHA512 bd5862b220bc9d77d938b87b1e2c974d0088239c51cd091b5e4d578d774e28aa6b25ab18936c9f388fd1ed3caeca264225c14cd5a85e749c3c3e148ca073a990 WHIRLPOOL 2b5ba4e2c91372e5cec355d0e6d651d4fd3de7b3d72839e855e099c75a9ffec172b43caff82d2cf7371fd3c7ac1ca1e71fc303eff75cd2e5afc352fbbf4dba42
+DIST mongo-tools-3.4.2.tar.gz 4700591 SHA256 3679576153ab1a9e1a7fe9811cb6d7c32c6d9320f07be9a94d064d6904618b5a SHA512 5ad4b5421acb10010f72f6b9f8342c095c4f571ac3cb9dc3db78251262f8285a4e2bddbeed3ad26c64f36d5b33ed7f43a759c74e00d2878c0ac6a71069508a2f WHIRLPOOL 208bd7116e1a7be2854f81df95d418667d50166d91522e14fdfa4e1f0b1ce007966fc5b0b1367f3be2c273fa7abbbfe04cb6e970a5010d44ac8542dc1bbd3424
diff --git a/app-admin/mongo-tools/mongo-tools-3.2.12.ebuild b/app-admin/mongo-tools/mongo-tools-3.2.12.ebuild
index f43e57c21823..5a82e19fa594 100644
--- a/app-admin/mongo-tools/mongo-tools-3.2.12.ebuild
+++ b/app-admin/mongo-tools/mongo-tools-3.2.12.ebuild
@@ -25,6 +25,7 @@ IUSE="sasl ssl"
RDEPEND="!<dev-db/mongodb-3.0.0"
DEPEND="${RDEPEND}
dev-lang/go:=
+ net-libs/libpcap
sasl? ( dev-libs/cyrus-sasl )
ssl? ( dev-libs/openssl )"
diff --git a/app-admin/mongo-tools/mongo-tools-3.4.2.ebuild b/app-admin/mongo-tools/mongo-tools-3.4.2.ebuild
new file mode 100644
index 000000000000..5a82e19fa594
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.4.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="http://www.mongodb.org"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl ssl"
+
+# Maintainer note:
+# openssl DEPEND constraint, see:
+# https://github.com/mongodb/mongo-tools/issues/11
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e 's|go build .*|go build -o "bin/$i" -tags "$tags" "$i/main/$i.go"|g' -i build.sh || die
+
+ # ensure we use bash wrt #582906
+ sed -e 's@/bin/sh@/bin/bash@g' -i build.sh || die
+
+ epatch "${FILESDIR}/${PN}-3.2.10-pie.patch"
+}
+
+src_compile() {
+ local myconf
+
+ if use sasl; then
+ myconf="${myconf} sasl"
+ fi
+
+ if use ssl; then
+ myconf="${myconf} ssl"
+ fi
+
+ ./build.sh ${myconf} || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}