summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-20 07:47:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-20 11:08:34 +0200
commite41c76c41e899ff25e03c260c3a83d3160e1b9de (patch)
treeba55daed751d1a2e568a8cdb20a10af790ce54bb /app-admin
parentdev-python/boto3: Bump to 1.18.2 (diff)
downloadgentoo-e41c76c41e899ff25e03c260c3a83d3160e1b9de.tar.gz
gentoo-e41c76c41e899ff25e03c260c3a83d3160e1b9de.tar.bz2
gentoo-e41c76c41e899ff25e03c260c3a83d3160e1b9de.zip
app-admin/awscli: Bump to 1.20.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.20.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 1cd9be509362..6f4f03388f55 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,3 +2,4 @@ DIST awscli-1.19.104.tar.gz 2024567 BLAKE2B 82662ffe6a05dd329210ff84962e1ad37ece
DIST awscli-1.19.112.tar.gz 2028010 BLAKE2B c5f973a2a0cf002038cdc46d0760f5e5fad942b1383f21819459d51fd3e3a17617e23d45d284345fac1760a812ffc81842068e8517bb500559a330ea8183968e SHA512 4ad9e960826baa057a2e72ddc2afce1012b766b5f691236435347c3e4ce210ee0b14003c16615262ec707d0c65b7f7f71a15fcf80a0fdfefb21ab6a28cfb1d55
DIST awscli-1.20.0.tar.gz 2028152 BLAKE2B d746335fc3414e773fbf3cb60b68ea1242162c7fb6f9e8222bec1bff992ec08e7239b9279de70551d05a99b2bd2743e8e2b8f65e01655574a542660fbb4a6ad7 SHA512 0aa478e9c28afa922958881f2f7795c6925e342964fb171176c81bce1fc4a0529dc9eb2fefaa05b670376781671e1531bbfe5114d0f0a748c964c5ace2c79ee4
DIST awscli-1.20.1.tar.gz 2028927 BLAKE2B bd535f1eba64987c8389c8003b90a1361e95db00a62f13138b35d0f4b6a5130b2e52e38663f4560bf58fe6b86e668ee142a0228001d8cde583d096ce81612264 SHA512 b704ff3f482dd2ccfdf78d01ccff214c9cb9f7b12b1af0a7c615b9567a931a8bc47a444dd8f136a958346750a60fb03a084993a7deb0c234448a9889918c97e6
+DIST awscli-1.20.2.tar.gz 2029411 BLAKE2B dad47f749af3c1e7bbeb291eb92889c7dc9bdc9e81ddb1fd3769897f94ba549123589a2ef8a34b88d8370cc6bb5ad45cc7b9fa06ec474620303a78ec3d64100e SHA512 6384a02a7bd3a8ea38cf46725daa25e7656e12c1f3f6465043efc223a82c605dbc916a26debc214ff6d364e81013e729acac424ccccc535785e8a3b68cfce2f6
diff --git a/app-admin/awscli/awscli-1.20.2.ebuild b/app-admin/awscli/awscli-1.20.2.ebuild
new file mode 100644
index 000000000000..ff429f8d3a3e
--- /dev/null
+++ b/app-admin/awscli/awscli-1.20.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install nose
+
+PATCHES=(
+ "${FILESDIR}"/awscli-1.19.47-py39.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ nosetests -v tests/{functional,unit} ||
+ die "Tests failed for ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}