summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-09-27 19:35:49 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-09-27 19:36:10 -0500
commite6cd971971f80d14d180d4dab7418a7b5fcc750e (patch)
tree075c2a03d195b1c59e369d218b368cc8a7b77f71 /app-admin
parentdev-libs/leatherman: 1.4.3 bump (diff)
downloadgentoo-e6cd971971f80d14d180d4dab7418a7b5fcc750e.tar.gz
gentoo-e6cd971971f80d14d180d4dab7418a7b5fcc750e.tar.bz2
gentoo-e6cd971971f80d14d180d4dab7418a7b5fcc750e.zip
app-admin/ansible: 2.5.10 bump
Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.5.10.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index da2217d62b91..f26f4a71cc81 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,3 +1,4 @@
+DIST ansible-2.5.10.tar.gz 10167484 BLAKE2B 0c60758d54fabef8037ce7e79d86c1508786a3e8cfe2cb1cc9d09cc24ece107414793f4dd12013dbc4c9a1354669288e0989374a20b7ebc035115dfd907c7279 SHA512 911f1f616206136708ceb4f9955e8bf309d7b506fcca9e0f31d770ead0a47c803d670909b6fe10b0d26056d3fd5c140e144132284ad5dbb618d3b013abc9385f
DIST ansible-2.5.6.tar.gz 10157989 BLAKE2B 07341ab7a087e3139442d5420b461ca332f3a9e550874a746f43904763660ef12c9a2041bb991eeb315abdc7f6e31e3615d9283f407003eddddf2b661331c59a SHA512 169badaa6a94d1ea2d16cb97c7e5eb0b8c225a455edfa95f3ad9e4ec968d5b9525dec4732b60e5ba5f92412f87d8aacc0b2299f2595f3bb820ad8604be8e76d6
DIST ansible-2.5.8.tar.gz 10169397 BLAKE2B 7cb0abb168af25a3cd7b94880309cf19f018a68277472afb24811bb4ccc329c129f754d2b97626f71052712690e372856bfb62345cdae74165eca38066e86779 SHA512 8de8ddf1925ef1465654f4bc1d54fd9f5f9d700ef2c5a4982684f3a4560ac933b05ff0661c34e61235006abc64fd6acf299d0c45f7b5796c3a89dda5382099ed
DIST ansible-2.5.9.tar.gz 10165368 BLAKE2B 10d30d3200702958e15695d8fb0aa84ee89b65f966b2879f3d9e89c1bae9d38bffa5936f88dbd7e3b0329f07e523677898230fff424d0d61f03cbe2dab8f3020 SHA512 0962d2f30030889b07e72346452f21cdc99305920bb8e246fc19d37ca4c837dbfba3230634db398b74959a6a67f4ed9dd097eb7783a2854f0969aeeab7e00341
diff --git a/app-admin/ansible/ansible-2.5.10.ebuild b/app-admin/ansible/ansible-2.5.10.ebuild
new file mode 100644
index 000000000000..71d5cc29eccb
--- /dev/null
+++ b/app-admin/ansible/ansible-2.5.10.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}