summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-16 03:51:49 +0000
committerSam James <sam@gentoo.org>2023-02-16 03:55:36 +0000
commitd8e6478a1a1c00f9d19f28a4a0f0bbfe535e0eea (patch)
tree74c5d4b49342f9844d06794b7beb808ab611e311 /app-antivirus
parentdev-python/pysnmp: enable py3.11 (diff)
downloadgentoo-d8e6478a1a1c00f9d19f28a4a0f0bbfe535e0eea.tar.gz
gentoo-d8e6478a1a1c00f9d19f28a4a0f0bbfe535e0eea.tar.bz2
gentoo-d8e6478a1a1c00f9d19f28a4a0f0bbfe535e0eea.zip
app-antivirus/fangfrisch: enable py3.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild b/app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild
index 6699e401c1fd..53c0fb8c80fa 100644
--- a/app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild
+++ b/app-antivirus/fangfrisch/fangfrisch-1.5.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{9,10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 readme.gentoo-r1 systemd
@@ -38,20 +38,19 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 x86"
+# Due to the nature of Fangfrisch, most tests require network
+# connectivity and/or access keys to download signature files.
+PROPERTIES="test_network"
+RESTRICT="test"
+
DEPEND=">=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.3.11[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
+distutils_enable_tests unittest
+
python_prepare_all() {
sed -i -e '/SQLAlchemy/d' setup.py || die
- # Due to the nature of Fangfrisch, most tests require network
- # connectivity and/or access keys to download signature files.
- # Also, my own CI reports show that the tests are successful,
- # so instead of a pick-and-choose approach, the complete tests
- # directory is removed in this ebuild. --RS
- if [ -d tests ]; then
- rm -r tests || die
- fi
distutils-r1_python_prepare_all
}