summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-05-17 22:59:20 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-17 23:09:46 +0200
commit09e068a2b18c9fed036814adae72b17514bf0510 (patch)
tree9c22bcf6d4b1c91043d725d92dd467314745d6f6 /app-arch/bzip3/bzip3-1.1.3-r1.ebuild
parentdev-scheme/guile-reader: drop useless static-libs USE flag (diff)
downloadgentoo-09e068a2b18c9fed036814adae72b17514bf0510.tar.gz
gentoo-09e068a2b18c9fed036814adae72b17514bf0510.tar.bz2
gentoo-09e068a2b18c9fed036814adae72b17514bf0510.zip
app-arch/bzip3: drop useless static-libs USE flag
as QA requested https://projects.gentoo.org/qa/policy-guide/installed-files.html#pg0302 also, use releases source for version 1.1.1 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-arch/bzip3/bzip3-1.1.3-r1.ebuild')
-rw-r--r--app-arch/bzip3/bzip3-1.1.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/bzip3/bzip3-1.1.3-r1.ebuild b/app-arch/bzip3/bzip3-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..3854b7aad967
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.1.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+
+src_configure() {
+ # ./configure script will default to Clang if it is found on the system,
+ # force the use of CC selected by the user with CC=$(tc-getCC)
+ econf CC=$(tc-getCC)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}