summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-11-09 22:18:23 +0200
committerJimi Huotari <chiitoo@gentoo.org>2022-11-10 14:55:36 +0200
commit28b44b0bb27a7dc32237b1f7a909410b00f43176 (patch)
tree99434438141bd5300994bdfc1a58ba5fefb632f7 /app-arch/lxqt-archiver
parentlxqt-base/lxqt-about: add version 1.2.0 (diff)
downloadgentoo-28b44b0bb27a7dc32237b1f7a909410b00f43176.tar.gz
gentoo-28b44b0bb27a7dc32237b1f7a909410b00f43176.tar.bz2
gentoo-28b44b0bb27a7dc32237b1f7a909410b00f43176.zip
app-arch/lxqt-archiver: add version 0.7.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'app-arch/lxqt-archiver')
-rw-r--r--app-arch/lxqt-archiver/Manifest1
-rw-r--r--app-arch/lxqt-archiver/lxqt-archiver-0.7.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-arch/lxqt-archiver/Manifest b/app-arch/lxqt-archiver/Manifest
index 081c1a3c2a4e..f6ce5dd77637 100644
--- a/app-arch/lxqt-archiver/Manifest
+++ b/app-arch/lxqt-archiver/Manifest
@@ -1,3 +1,4 @@
DIST lxqt-archiver-0.4.0.tar.xz 167124 BLAKE2B 2d9295200c284e2dc0c2b538a92952dd0a11882211e5d1d5838141583b4a595b65c26a057e5c9733190182a5f78958e15d0e086356d75dd4e0c72d3510a34cfc SHA512 e1b323cd118af3726009e153c4f9766ec53b29fa0280530da16e2101d36ec45b55de0fe3d87c1386a4e5b3d88712fd209659b4ebb9344af689812600ae136ed6
DIST lxqt-archiver-0.5.0.tar.xz 176312 BLAKE2B c7e843ba59e3c313fbd1b32f848fb3c988fe144886f64b284f49716a200866a8c22d68b00ece8f61b103d8ab55f4de6a2a86371637b56a842fb516520af29964 SHA512 01747499fece79010f359bfe5987dd0ef96daa92269659dc64543a78a4540ed7e5ff2e0b2ae6ab620c6be7244f4e350a18aa08657e7d84429fa20d0a264977c6
DIST lxqt-archiver-0.6.0.tar.xz 180844 BLAKE2B 99de054cb3e002aa26637149611e6f054a8a406a3751b3b79584011616a8359fa003909f5059479979ff4b36ffa6a31807702b3b79465ad9ef75dbe008d51a32 SHA512 e714969ac285969b845cc3b293bf74fd3986be09ec0315aa11aca553e432397b8b68ec3830ae009f5fa950866b299e71aa89794de5af329f7012cb2524b310df
+DIST lxqt-archiver-0.7.0.tar.xz 181612 BLAKE2B 41ad378f20a9a8f3d7ccfc7406d480eecfad41c991781f503947b37ee26eec5de38b44ea318507dc209a2f2f6d68db65e0f9cdf61920a47fb2d02dd975960f86 SHA512 d86fd636b1b2345ead8c4dc0161311b3e361d274902c5b34b9aaccf1a0b9af46d329fbec0d2249197b8e1c837d6949f723451f67fdc9ca4c6b7f1c2cf59daeca
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-0.7.0.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-0.7.0.ebuild
new file mode 100644
index 000000000000..5c83cb945290
--- /dev/null
+++ b/app-arch/lxqt-archiver/lxqt-archiver-0.7.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI File Archiver"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.12.0
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtx11extras-5.15:5
+ >=x11-libs/libfm-qt-1.2:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "Please note that this is only a graphical front-end, and additional"
+ elog "packages are needed to have support for specific file formats."
+ elog "For example, to be able to work with the 7-Zip format, the"
+ elog "'app-arch/p7zip' package may be used."
+ elog "For the full list of supported formats, see the 'README.md' file:"
+ elog "https://github.com/lxqt/lxqt-archiver/blob/master/README.md"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}