summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-01-27 15:48:12 +0100
committerMichał Górny <mgorny@gentoo.org>2016-01-27 15:49:11 +0100
commitb8680d26f53304b6dc2f9122fb1dfb012c4af3fe (patch)
tree6e7b43a4170f87ce12c4546b8761b6af45142784 /app-arch/pdlzip/pdlzip-1.6.ebuild
parentapp-arch/lzlib: Use correct license (diff)
downloadgentoo-b8680d26f53304b6dc2f9122fb1dfb012c4af3fe.tar.gz
gentoo-b8680d26f53304b6dc2f9122fb1dfb012c4af3fe.tar.bz2
gentoo-b8680d26f53304b6dc2f9122fb1dfb012c4af3fe.zip
app-arch/pdlzip: Bump to 1.6
Diffstat (limited to 'app-arch/pdlzip/pdlzip-1.6.ebuild')
-rw-r--r--app-arch/pdlzip/pdlzip-1.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/pdlzip/pdlzip-1.6.ebuild b/app-arch/pdlzip/pdlzip-1.6.ebuild
new file mode 100644
index 000000000000..4c1b4e464d3e
--- /dev/null
+++ b/app-arch/pdlzip/pdlzip-1.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Public-domain version of lzip compressor"
+HOMEPAGE="http://www.nongnu.org/lzip/pdlzip.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/pdlzip/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}