summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Miller <alex.miller@gmx.de>2020-11-11 16:08:49 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-19 12:21:59 +0200
commit4f3811aa431fa66e4baa15faa5242e3a9e0858c2 (patch)
treeb18e96bf1c5608203d1799e4c98d25cd6ba7618a /app-arch/torrentzip
parentsci-electronics/kicad-templates: remove empty global variables (diff)
downloadgentoo-4f3811aa431fa66e4baa15faa5242e3a9e0858c2.tar.gz
gentoo-4f3811aa431fa66e4baa15faa5242e3a9e0858c2.tar.bz2
gentoo-4f3811aa431fa66e4baa15faa5242e3a9e0858c2.zip
app-arch/torrentzip: Fix building with autoconf-2.70
* EAPI=7 * Drop leftover dependency on app-arch/unzip. * Add a patch that fixes underquoting in configure.ac which caused aclocal to fail with recent autoconf-2.70 betas. Closes: https://bugs.gentoo.org/751235 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexander Miller <alex.miller@gmx.de> Closes: https://github.com/gentoo/gentoo/pull/18225 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-arch/torrentzip')
-rw-r--r--app-arch/torrentzip/files/torrentzip-0.9-autoconf-quote.patch8
-rw-r--r--app-arch/torrentzip/torrentzip-0.9-r1.ebuild29
2 files changed, 37 insertions, 0 deletions
diff --git a/app-arch/torrentzip/files/torrentzip-0.9-autoconf-quote.patch b/app-arch/torrentzip/files/torrentzip-0.9-autoconf-quote.patch
new file mode 100644
index 000000000000..c71542f4c7dd
--- /dev/null
+++ b/app-arch/torrentzip/files/torrentzip-0.9-autoconf-quote.patch
@@ -0,0 +1,8 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,4 +1,4 @@
+-AC_INIT([TorrentZip], [0.0], [StatMan, shindakun, Ultrasubmarine, r3nh03k <http://trrntzip.sf.net>], [trrntzip])
++AC_INIT([TorrentZip], [0.9], [[StatMan, shindakun, Ultrasubmarine, r3nh03k <http://trrntzip.sf.net>]], [trrntzip])
+
+ AM_INIT_AUTOMAKE
+ AM_CONFIG_HEADER(config.h)
diff --git a/app-arch/torrentzip/torrentzip-0.9-r1.ebuild b/app-arch/torrentzip/torrentzip-0.9-r1.ebuild
new file mode 100644
index 000000000000..bf160c6743f0
--- /dev/null
+++ b/app-arch/torrentzip/torrentzip-0.9-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Create identical zip archives over multiple systems"
+HOMEPAGE="https://sourceforge.net/projects/trrntzip"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+
+DEPEND="${RDEPEND}"
+
+DOCS=(README AUTHORS)
+
+PATCHES=("${FILESDIR}/${P}-autoconf-quote.patch")
+
+src_prepare() {
+ default
+ export CPPFLAGS+=" -DOF\\(args\\)=args"
+ eautoreconf
+}