summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2015-09-07 11:54:07 +0200
committerFabian Groffen <grobian@gentoo.org>2015-09-07 11:54:27 +0200
commitc21f90bf6a4e573b15f73e57454ee6199d0f3f31 (patch)
tree8d91a185bdf8cfe5b70b0393f968fd43cf4ca822 /app-arch/unrar-gpl/files
parentdev-ruby/spork: Remove old (diff)
downloadgentoo-c21f90bf6a4e573b15f73e57454ee6199d0f3f31.tar.gz
gentoo-c21f90bf6a4e573b15f73e57454ee6199d0f3f31.tar.bz2
gentoo-c21f90bf6a4e573b15f73e57454ee6199d0f3f31.zip
app-arch/unrar-gpl: add support for non-linux platforms (Prefix)
Package-Manager: portage-2.2.20-prefix
Diffstat (limited to 'app-arch/unrar-gpl/files')
-rw-r--r--app-arch/unrar-gpl/files/unrar-gpl-0.0.1-solaris.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/unrar-gpl/files/unrar-gpl-0.0.1-solaris.patch b/app-arch/unrar-gpl/files/unrar-gpl-0.0.1-solaris.patch
new file mode 100644
index 000000000000..f1cf8ef2338a
--- /dev/null
+++ b/app-arch/unrar-gpl/files/unrar-gpl-0.0.1-solaris.patch
@@ -0,0 +1,63 @@
+* grobian@gentoo.org: allow compilation on non glibc hosts by use of an
+ external library for argp, and check for certain
+ headers before including them
+
+--- configure.ac
++++ configure.ac
+@@ -14,7 +14,7 @@
+
+ # Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS([limits.h stdlib.h string.h unistd.h])
++AC_CHECK_HEADERS([limits.h stdlib.h string.h unistd.h error.h])
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+@@ -24,6 +24,7 @@
+ AC_FUNC_MALLOC
+ AC_FUNC_REALLOC
+ AC_CHECK_FUNCS([atexit realpath setenv strchr])
++AC_SEARCH_LIBS([argp_usage], [argp])
+
+ AC_CONFIG_FILES([Makefile
+ src/Makefile])
+--- src/unrar.c
++++ src/unrar.c
+@@ -24,7 +24,9 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <time.h>
++#ifdef HAVE_ERROR_H
+ #include <error.h>
++#endif
+ #include <errno.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+--- src/opts.c
++++ src/opts.c
+@@ -22,7 +22,9 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#ifdef HAVE_ERROR_H
+ #include <error.h>
++#endif
+ #include <argp.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+--- src/opts.h
++++ src/opts.h
+@@ -56,4 +56,13 @@
+ int parse_opts (int argc, char **argv, struct arguments_t *arguments);
+ int compat_parse_opts (int argc, char **argv, struct arguments_t *arguments);
+
++#ifndef HAVE_ERROR_H
++#define error(S, E, ...) \
++ fflush(stdout); \
++ fprintf(stderr, "unrar: " __VA_ARGS__); \
++ if (E != 0) fprintf(stderr, ": %s", strerror(E)); \
++ fprintf(stderr, "\n"); \
++ if (S != 0) exit(S);
++#endif
++
+ #endif