summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-02-28 14:15:32 -0500
committerMike Frysinger <vapier@gentoo.org>2016-02-28 14:15:42 -0500
commitf30bed50f18566190979cde0412e9919b0934a44 (patch)
tree408d3b8683a4d89529c65a86e0061a63c79aac81 /app-arch/unzip
parentMerge github#929: dev-util/idea-ultimate: Version bump to 15.0.4. (diff)
downloadgentoo-f30bed50f18566190979cde0412e9919b0934a44.tar.gz
gentoo-f30bed50f18566190979cde0412e9919b0934a44.tar.bz2
gentoo-f30bed50f18566190979cde0412e9919b0934a44.zip
app-arch/unzip: expand toolchain sed to cover more cases #575710
Diffstat (limited to 'app-arch/unzip')
-rw-r--r--app-arch/unzip/unzip-6.0-r3.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-arch/unzip/unzip-6.0-r3.ebuild b/app-arch/unzip/unzip-6.0-r3.ebuild
index 210563bcb5a1..a1ea7610becc 100644
--- a/app-arch/unzip/unzip-6.0-r3.ebuild
+++ b/app-arch/unzip/unzip-6.0-r3.ebuild
@@ -25,13 +25,13 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch "${FILESDIR}"/${P}-no-exec-stack.patch
use natspec && epatch "${FILESDIR}/${PN}-6.0-natspec.patch" #275244
- sed -i \
+ sed -i -r \
-e '/^CFLAGS/d' \
- -e '/CFLAGS/s:-O[0-9]\?:$(CFLAGS) $(CPPFLAGS):' \
+ -e '/CFLAGS/s:-O[0-9]?:$(CFLAGS) $(CPPFLAGS):' \
-e '/^STRIP/s:=.*:=true:' \
- -e "s:\<CC=gcc\>:CC=\"$(tc-getCC)\":" \
- -e "s:\<LD=gcc\>:LD=\"$(tc-getCC)\":" \
- -e "s:\<AS=gcc\>:AS=\"$(tc-getCC)\":" \
+ -e "s:\<CC *= *\"?g?cc2?\"?\>:CC=\"$(tc-getCC)\":" \
+ -e "s:\<LD *= *\"?(g?cc2?|ld)\"?\>:LD=\"$(tc-getCC)\":" \
+ -e "s:\<AS *= *\"?(g?cc2?|as)\"?\>:AS=\"$(tc-getCC)\":" \
-e 's:LF2 = -s:LF2 = :' \
-e 's:LF = :LF = $(LDFLAGS) :' \
-e 's:SL = :SL = $(LDFLAGS) :' \