summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-15 10:19:43 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-02-25 08:04:48 +0200
commit72b4da71f8754510153532a6bf3681f65fd6505f (patch)
tree49e32549ed588cccf9f5597779e23cdd7d17fbb7 /app-arch/upx
parentnet-im/telegram-desktop-bin: Drop old (diff)
downloadgentoo-72b4da71f8754510153532a6bf3681f65fd6505f.tar.gz
gentoo-72b4da71f8754510153532a6bf3681f65fd6505f.tar.bz2
gentoo-72b4da71f8754510153532a6bf3681f65fd6505f.zip
app-arch/upx: update to 3.96
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-arch/upx')
-rw-r--r--app-arch/upx/Manifest1
-rw-r--r--app-arch/upx/upx-3.96.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/upx/Manifest b/app-arch/upx/Manifest
index b1b537bdcd18..3aa001eabb8d 100644
--- a/app-arch/upx/Manifest
+++ b/app-arch/upx/Manifest
@@ -1 +1,2 @@
DIST upx-3.95-src.tar.xz 790776 BLAKE2B e7e5e24ba3675ab9f9f3daa36d6d3f00b6af614c2ca64c4d185a065afcdc02373ccf0200f7116ebbfaa1f9b961078f40296b1c716eca80aba86e95d6a9463b99 SHA512 0e1d3e26462057f16587197e73301957e870107808fdbcd24d9976094dfa0e5efbe8da0f9b6732a99f05990dcd4be242a87ea19a7110dc052c6dc982cd596416
+DIST upx-3.96-src.tar.xz 792524 BLAKE2B 21af85dbcfdd1bf0151a653c865db13c9f30b9de0b9b4b94557ddd55736c7053dd829c5d72b9a7e5aa94a71ecc0151145dd66d7d98ded178c50ff7357d0ba442 SHA512 2d4d1be21d274d9bfdee9b9815396f5e5ff0bcdfb781b7be5fafa4d1e224028e412ec5f5ba607c482671aae27ccf9069abb2db0fb58f78f3a102a51897df2b11
diff --git a/app-arch/upx/upx-3.96.ebuild b/app-arch/upx/upx-3.96.ebuild
new file mode 100644
index 000000000000..73fe7d2befec
--- /dev/null
+++ b/app-arch/upx/upx-3.96.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
+HOMEPAGE="http://upx.github.io/"
+SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
+
+LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/ucl-1.03
+ sys-libs/zlib
+ !app-arch/upx-bin"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${P}-src"
+
+src_compile() {
+ tc-export CXX
+ emake CXXFLAGS_WERROR="" all
+}
+
+src_install() {
+ newbin src/upx.out upx
+ dodoc BUGS NEWS PROJECTS README* THANKS doc/*.txt doc/upx.html
+ doman doc/upx.1
+}