summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-02-11 17:24:36 -0700
committerTim Harder <radhermit@gentoo.org>2020-02-11 17:50:05 -0700
commit0a83de73f463d850c0769ea9795a9d2729e65395 (patch)
tree71d31dde35e7a3b11ad9047496511f8a77f8d0a4 /app-arch/vimball/vimball-9999.ebuild
parentdev-util/bite: drop old, unreleased package (diff)
downloadgentoo-0a83de73f463d850c0769ea9795a9d2729e65395.tar.gz
gentoo-0a83de73f463d850c0769ea9795a9d2729e65395.tar.bz2
gentoo-0a83de73f463d850c0769ea9795a9d2729e65395.zip
app-arch/vimball: add py38 compat and fix DISTUTILS_USE_SETUPTOOLS
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-arch/vimball/vimball-9999.ebuild')
-rw-r--r--app-arch/vimball/vimball-9999.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/app-arch/vimball/vimball-9999.ebuild b/app-arch/vimball/vimball-9999.ebuild
index 38f71ad8b03d..9bcf7f649ea8 100644
--- a/app-arch/vimball/vimball-9999.ebuild
+++ b/app-arch/vimball/vimball-9999.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -21,8 +22,6 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${BDEPEND}"
DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {