summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-08-14 17:05:02 -0600
committerTim Harder <radhermit@gentoo.org>2019-08-14 17:14:41 -0600
commitec4a00e9005a7fd27d83aadaec7d6c739ac915e2 (patch)
treeb1d62fece40e6a92bb15d8d7e6ff0c26a4e421d8 /app-arch/vimball/vimball-9999.ebuild
parentapp-arch/pigz: add missing conditional test RESTRICT (diff)
downloadgentoo-ec4a00e9005a7fd27d83aadaec7d6c739ac915e2.tar.gz
gentoo-ec4a00e9005a7fd27d83aadaec7d6c739ac915e2.tar.bz2
gentoo-ec4a00e9005a7fd27d83aadaec7d6c739ac915e2.zip
app-arch/vimball: bump to EAPI 7, add py37 support, and missing test RESTRICT
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-arch/vimball/vimball-9999.ebuild')
-rw-r--r--app-arch/vimball/vimball-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-arch/vimball/vimball-9999.ebuild b/app-arch/vimball/vimball-9999.ebuild
index 82a39960d3ea..280fc206bc04 100644
--- a/app-arch/vimball/vimball-9999.ebuild
+++ b/app-arch/vimball/vimball-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -19,10 +19,11 @@ HOMEPAGE="https://github.com/radhermit/vimball"
LICENSE="MIT"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}"
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {
esetup.py test