summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-05 02:13:04 +0100
committerSam James <sam@gentoo.org>2022-07-05 02:13:25 +0100
commit188ca6ba0a28ffdcbb063d0bf126a2ed8769448b (patch)
treecec15fe78896739f5333288f2751d52d40f6118b /app-arch
parentapp-emulation/qemu: forward 7.0.0-also-build-virtfs-proxy-helper.patch to avo... (diff)
downloadgentoo-188ca6ba0a28ffdcbb063d0bf126a2ed8769448b.tar.gz
gentoo-188ca6ba0a28ffdcbb063d0bf126a2ed8769448b.tar.bz2
gentoo-188ca6ba0a28ffdcbb063d0bf126a2ed8769448b.zip
app-arch/rpm: add 4.17.1
Bug: https://bugs.gentoo.org/830380 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/Manifest1
-rw-r--r--app-arch/rpm/rpm-4.17.1.ebuild161
2 files changed, 162 insertions, 0 deletions
diff --git a/app-arch/rpm/Manifest b/app-arch/rpm/Manifest
index 949c468c6cc6..620e4e3efa8b 100644
--- a/app-arch/rpm/Manifest
+++ b/app-arch/rpm/Manifest
@@ -1 +1,2 @@
DIST rpm-4.17.0.tar.bz2 4514138 BLAKE2B e2618f7ac59189fb880d6be853aae99080b5008865298d095a123a010ab70f9e2e3ad9402124afbf8291a3863e9e805c9c65ab47cc435df82a729e81984394bf SHA512 d32af8649c6d47796a645b6ecbe580df97f5423bfb17414d5ed0016373f5cfab86ebcfad6c480fb8bfafaf3a960f9bc095ef6faad7b40bdb208cc60e4080b0c8
+DIST rpm-4.17.1.tar.bz2 4642016 BLAKE2B d82926845e523c82fcf6a985d8de00f7a5bcc981e15d3115c310260713c482dc43e23b43f887644415b5a51ee382297d6d3569b6914595c91b9b89cc813af8e8 SHA512 d0429510140f25a25b6c9441abe2027d27c485bbd4969752f69e1c843435c9508b9f85e5bb68085dd64b7da533801aa5c04d8c9d962e08d2ddd3199d0265cc85
diff --git a/app-arch/rpm/rpm-4.17.1.ebuild b/app-arch/rpm/rpm-4.17.1.ebuild
new file mode 100644
index 000000000000..ac7a9dc24a1f
--- /dev/null
+++ b/app-arch/rpm/rpm-4.17.1.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{3,4} )
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools lua-single perl-module python-single-r1 toolchain-funcs
+
+DESCRIPTION="Red Hat Package Management Utils"
+HOMEPAGE="https://rpm.org
+ https://github.com/rpm-software-management/rpm"
+SRC_URI="https://ftp.osuosl.org/pub/rpm/releases/rpm-$(ver_cut 1-2).x/${P}.tar.bz2
+ http://ftp.rpm.org/releases/rpm-$(ver_cut 1-2).x/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# Tests are broken. See bug 657500
+RESTRICT="test"
+
+IUSE="acl audit caps +berkdb doc dbus nls openmp python selinux +sqlite test +zstd"
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="!app-arch/rpm5
+ app-arch/libarchive:=
+ >=app-arch/bzip2-1.0.1
+ app-arch/xz-utils
+ >=app-crypt/gnupg-1.2
+ >=dev-lang/perl-5.8.8
+ dev-libs/elfutils
+ dev-libs/libgcrypt:=
+ >=dev-libs/popt-1.7
+ sys-apps/file
+ >=sys-libs/zlib-1.2.3-r1
+ virtual/libintl
+ ${LUA_DEPS}
+ acl? ( virtual/acl )
+ audit? ( sys-process/audit )
+ caps? ( >=sys-libs/libcap-2.0 )
+ dbus? ( sys-apps/dbus )
+ sqlite? ( dev-db/sqlite:3 )
+ python? ( ${PYTHON_DEPS} )
+ nls? ( virtual/libintl )
+ zstd? ( app-arch/zstd:= )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+ test? ( sys-apps/fakechroot )
+"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-rpm )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.8.1-db-path.patch
+ "${FILESDIR}"/${PN}-4.17.0-libdir.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ lua-single_pkg_setup
+
+ use python && python-single-r1_pkg_setup
+
+ # Added USE=openmp and this check for bug #779769
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+
+ # bug #356769
+ sed -i 's:%{_var}/tmp:/var/tmp:' macros.in || die "Fixing tmppath failed"
+ # bug #492642
+ sed -i "s:@__PYTHON@:${PYTHON}:" macros.in || die "Fixing %__python failed"
+
+ # Prevent automake maintainer mode from kicking in (bug #450448).
+ #touch -r Makefile.am preinstall.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # rpm no longer supports berkdb, but has readonly support.
+ # https://github.com/rpm-software-management/rpm/commit/4290300e24c5ab17c615b6108f38438e31eeb1d0
+ econf \
+ --without-selinux \
+ --disable-inhibit-plugin \
+ --with-crypto=libgcrypt \
+ $(use_enable berkdb bdb-ro) \
+ $(use_enable python) \
+ $(use_enable nls) \
+ $(use_enable openmp) \
+ $(use_enable dbus inhibit-plugin) \
+ $(use_enable sqlite) \
+ $(use_with caps cap) \
+ $(use_with acl) \
+ $(use_with audit) \
+ $(use_enable zstd zstd $(usex zstd yes no))
+}
+
+src_test() {
+ # Known to fail with FEATURES=usersandbox (bug #657500)
+ if has usersandbox ${FEATURES} ; then
+ ewarn "You are emerging ${P} with 'usersandbox' enabled." \
+ "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ fi
+
+ emake check
+}
+
+src_install() {
+ default
+
+ # Remove la files
+ find "${ED}" -name '*.la' -delete || die
+
+ # Fix symlinks to /bin/rpm (bug #349840)
+ for binary in rpmquery rpmverify; do
+ ln -sf rpm "${ED}"/usr/bin/${binary} || die
+ done
+
+ if ! use nls; then
+ rm -rf "${ED}"/usr/share/man/?? || die
+ fi
+
+ keepdir /usr/src/rpm/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
+
+ dodoc CREDITS README*
+ if use doc; then
+ local docname
+ for docname in librpm; do
+ docinto "html/${docname}"
+ dodoc -r "docs/${docname}/html/."
+ done
+ fi
+
+ # Fix perllocal.pod file collision
+ perl_delete_localpod
+
+ use python && python_optimize
+}
+
+pkg_postinst() {
+ if [[ -f "${EROOT}"/var/lib/rpm/Packages ]] ; then
+ einfo "RPM database found... Rebuilding database (may take a while)..."
+ "${EROOT}"/usr/bin/rpmdb --rebuilddb --root="${EROOT}/" || die
+ else
+ einfo "No RPM database found... Creating database..."
+ "${EROOT}"/usr/bin/rpmdb --initdb --root="${EROOT}/" || die
+ fi
+}