summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-13 07:58:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-13 08:15:28 +0200
commit27f9d1947a845fb7cfe91820f54f221b76f02e6c (patch)
tree6f7968075fdeefe0e0c67b451d21e3822373744f /app-arch
parentdev-python/pyjwt: Bump to 2.4.0 (diff)
downloadgentoo-27f9d1947a845fb7cfe91820f54f221b76f02e6c.tar.gz
gentoo-27f9d1947a845fb7cfe91820f54f221b76f02e6c.tar.bz2
gentoo-27f9d1947a845fb7cfe91820f54f221b76f02e6c.zip
app-arch/xarchiver: Bump to 0.5.4.18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/xarchiver/Manifest1
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.4.18.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/xarchiver/Manifest b/app-arch/xarchiver/Manifest
index 25bf15a6e329..7cb2ced48090 100644
--- a/app-arch/xarchiver/Manifest
+++ b/app-arch/xarchiver/Manifest
@@ -1 +1,2 @@
DIST xarchiver-0.5.4.17.tar.gz 1077111 BLAKE2B f68f22258dbfaeb37333fab3d2ea1b06e23e143f90df6cd94f7601961636d1e5a929e1353ac956ac9a7341813593fcfb35d5197666dbb0920ddf63e4365f34e1 SHA512 5b19fd0fb90f99aee0ac2576bc4efce9ef4eef9119fc118815f6d925e3877c0895475fbdf7363d8adfb6371fb7fd73299ea3a7cb3b6d9fff19c89d1d287d3a84
+DIST xarchiver-0.5.4.18.tar.gz 1112838 BLAKE2B baeab65c9f81eecf070185fb3718b3e8a460e94393dfcdf38ad8bfb2a771c6f98a8638a28c43aa99d05a95772ca7e1546d9be1b602e22a715d5827350976f9d8 SHA512 a33236839d325a2d706fd0a9e2257ab5289895b030450b2060da856c047e5676ac5686312f8d00d3f38d329d0cf39fb22330a7c902b3ff5943856801435f6970
diff --git a/app-arch/xarchiver/xarchiver-0.5.4.18.ebuild b/app-arch/xarchiver/xarchiver-0.5.4.18.ebuild
new file mode 100644
index 000000000000..2a6e5c75e1c3
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.4.18.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A GTK+ archive manager that can be used with Thunar"
+HOMEPAGE="https://github.com/ib/xarchiver/"
+SRC_URI="https://github.com/ib/xarchiver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+# older pigz versions have incompatible command-line processing
+# https://bugs.gentoo.org/661464
+DEPEND="
+ >=dev-libs/glib-2:=
+ x11-libs/gtk+:3=
+ !!<app-arch/pigz-2.4[symlink]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "You need external programs for some formats, including:"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}