summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2020-10-01 12:15:19 +0100
committerTony Vroon <chainsaw@gentoo.org>2020-10-01 12:17:52 +0100
commit3bfda681c33a63ebe64a04f5ef0084c3d07990aa (patch)
tree781fd060c428b5dcf650de00b5d167f53d085ce2 /app-arch
parentdev-python/ipython: Stabilize 7.18.1 ALLARCHES, #745534 (diff)
downloadgentoo-3bfda681c33a63ebe64a04f5ef0084c3d07990aa.tar.gz
gentoo-3bfda681c33a63ebe64a04f5ef0084c3d07990aa.tar.bz2
gentoo-3bfda681c33a63ebe64a04f5ef0084c3d07990aa.zip
app-arch/rpm: Version bump to 4.16.0
This has USE="zstd" defaulted to on to ensure Fedora 31 packages are recognised without issue. Closes: https://bugs.gentoo.org/520312 Closes: https://bugs.gentoo.org/730354 Closes: https://bugs.gentoo.org/740078 Signed-Off-By: Tony Vroon <chainsaw@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/Manifest1
-rw-r--r--app-arch/rpm/files/rpm-4.16.0-autotools.patch13
-rw-r--r--app-arch/rpm/files/rpm-4.16.0-libdir.patch34
-rw-r--r--app-arch/rpm/rpm-4.16.0.ebuild139
4 files changed, 187 insertions, 0 deletions
diff --git a/app-arch/rpm/Manifest b/app-arch/rpm/Manifest
index 7529e899a903..08fa264efdf5 100644
--- a/app-arch/rpm/Manifest
+++ b/app-arch/rpm/Manifest
@@ -1 +1,2 @@
DIST rpm-4.14.2.1.tar.bz2 4156574 BLAKE2B 2eb0cf621eecef7d8977d28d52be922156ceb64b14d2aefda0f5a927b90cf3d3e9c055d773e05ed52422254397153b79557dc94bdb43ca28a2ea126153a43c1f SHA512 0aad457f91918904c15649a1764ce7cbfaf38e083678031286e866f7997be0435a6b7b73596706d97e9263cff7b4df4a3150b142d81e6e3fddbfcf67bd83f990
+DIST rpm-4.16.0.tar.bz2 4341683 BLAKE2B 5161e5dcc6d9a1f1d4b8e44740fb368050b808fd9e8b8276fb17b530a4642e1b9ad104b5a30c0071215aef7f823eeab10988dd41f73af1c52d575529c374b5eb SHA512 177119c3ac3d48980db55bb4ba0fdbb2a911968e5efc690bfa8cc343f850fc90531cc0dee6dd8e45d2b14f0d951ced35bd8893d24011b7f270745d281ddf4e3d
diff --git a/app-arch/rpm/files/rpm-4.16.0-autotools.patch b/app-arch/rpm/files/rpm-4.16.0-autotools.patch
new file mode 100644
index 000000000000..9b1f71ad86e5
--- /dev/null
+++ b/app-arch/rpm/files/rpm-4.16.0-autotools.patch
@@ -0,0 +1,13 @@
+diff -uNr rpm-4.16.0.ORIG/configure.ac rpm-4.16.0/configure.ac
+--- rpm-4.16.0.ORIG/configure.ac 2020-10-01 11:02:21.605485875 +0100
++++ rpm-4.16.0/configure.ac 2020-10-01 11:05:34.077157904 +0100
+@@ -552,9 +552,6 @@
+
+ AM_CONDITIONAL([BDB], [test "x$have_bdb" != "xno"])
+ AM_CONDITIONAL([WITH_INTERNAL_DB],[test "x$have_bdb" = "xinternal"])
+-if test "x$have_bdb" = "xinternal"; then
+- AC_CONFIG_SUBDIRS(db3)
+-fi
+
+
+ #=================
diff --git a/app-arch/rpm/files/rpm-4.16.0-libdir.patch b/app-arch/rpm/files/rpm-4.16.0-libdir.patch
new file mode 100644
index 000000000000..c9f5f297233b
--- /dev/null
+++ b/app-arch/rpm/files/rpm-4.16.0-libdir.patch
@@ -0,0 +1,34 @@
+diff -uNr rpm-4.16.0.ORIG/configure.ac rpm-4.16.0/configure.ac
+--- rpm-4.16.0.ORIG/configure.ac 2020-10-01 11:08:43.780842602 +0100
++++ rpm-4.16.0/configure.ac 2020-10-01 11:09:03.533705353 +0100
+@@ -935,13 +935,7 @@
+ AC_DEFINE_UNQUOTED([RUNDIR],["${RUNDIR}"],[run-time variable directory])
+ AC_SUBST(RUNDIR)
+
+-if test X"$prefix" = XNONE ; then
+- usrprefix="$ac_default_prefix"
+-else
+- usrprefix=$prefix
+-fi
+-
+-RPMCONFIGDIR="`echo ${usrprefix}/lib/rpm`"
++RPMCONFIGDIR="`echo ${libexecdir}/rpm/`"
+ AC_SUBST(RPMCONFIGDIR)
+
+ AC_SUBST(OBJDUMP)
+diff -uNr rpm-4.16.0.ORIG/rpm.am rpm-4.16.0/rpm.am
+--- rpm-4.16.0.ORIG/rpm.am 2020-10-01 11:08:43.743842859 +0100
++++ rpm-4.16.0/rpm.am 2020-10-01 11:09:03.533705353 +0100
+@@ -1,10 +1,8 @@
+ # Internal binaries
+-## HACK: It probably should be $(libexecdir)/rpm or $(libdir)/rpm
+-rpmlibexecdir = $(prefix)/lib/rpm
++rpmlibexecdir = $(pkglibexecdir)
+
+ # Host independent config files
+-## HACK: it probably should be $(datadir)/rpm
+-rpmconfigdir = $(prefix)/lib/rpm
++rpmconfigdir = $(pkglibexecdir)
+
+ # Libtool version (current-revision-age) for all our libraries
+ rpm_version_info = 10:0:1
diff --git a/app-arch/rpm/rpm-4.16.0.ebuild b/app-arch/rpm/rpm-4.16.0.ebuild
new file mode 100644
index 000000000000..67132e47a629
--- /dev/null
+++ b/app-arch/rpm/rpm-4.16.0.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit autotools flag-o-matic perl-module python-single-r1
+
+DESCRIPTION="Red Hat Package Management Utils"
+HOMEPAGE="https://rpm.org
+ https://github.com/rpm-software-management/rpm"
+SRC_URI="http://ftp.rpm.org/releases/rpm-$(ver_cut 1-2).x/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# Tests are broken. See bug 657500
+RESTRICT="test"
+
+IUSE="acl caps doc dbus lua nls python selinux test +zstd"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+CDEPEND="!app-arch/rpm5
+ app-arch/libarchive
+ >=sys-libs/db-4.5:*
+ >=sys-libs/zlib-1.2.3-r1
+ >=app-arch/bzip2-1.0.1
+ >=dev-libs/popt-1.7
+ >=app-crypt/gnupg-1.2
+ dbus? ( sys-apps/dbus )
+ dev-libs/elfutils
+ virtual/libintl
+ >=dev-lang/perl-5.8.8
+ dev-libs/nss
+ python? ( ${PYTHON_DEPS} )
+ nls? ( virtual/libintl )
+ lua? ( dev-lang/lua:5.2 )
+ acl? ( virtual/acl )
+ caps? ( >=sys-libs/libcap-2.0 )
+ zstd? ( app-arch/zstd )
+"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+ test? ( sys-apps/fakechroot )
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-rpm )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-autotools.patch
+ eapply "${FILESDIR}"/${PN}-4.8.1-db-path.patch
+ eapply "${FILESDIR}"/${P}-libdir.patch
+
+ # fix #356769
+ sed -i 's:%{_var}/tmp:/var/tmp:' macros.in || die "Fixing tmppath failed"
+ # fix #492642
+ sed -i "s:@__PYTHON@:${PYTHON}:" macros.in || die "Fixing %__python failed"
+
+ eapply_user
+
+ eautoreconf
+
+ # Prevent automake maintainer mode from kicking in (#450448).
+ touch -r Makefile.am preinstall.am
+}
+
+src_configure() {
+ append-cppflags -I"${EPREFIX}/usr/include/nss" -I"${EPREFIX}/usr/include/nspr"
+ econf \
+ --without-selinux \
+ --with-crypto=nss \
+ $(use_enable python) \
+ $(use_enable nls) \
+ $(use_enable dbus inhibit-plugin) \
+ $(use_with lua) \
+ $(use_with caps cap) \
+ $(use_with acl) \
+ $(use_enable zstd zstd $(usex zstd yes no))
+}
+
+src_install() {
+ default
+
+ # remove la files
+ find "${ED}" -name '*.la' -delete || die
+
+ # fix symlinks to /bin/rpm (#349840)
+ for binary in rpmquery rpmverify;do
+ ln -sf rpm "${ED}"/usr/bin/${binary} || die
+ done
+
+ if ! use nls; then
+ rm -rf "${ED}"/usr/share/man/?? || die
+ fi
+
+ keepdir /usr/src/rpm/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
+
+ dodoc CREDITS README*
+ if use doc; then
+ for docname in librpm; do
+ docinto "html/${docname}"
+ dodoc -r "doc/${docname}/html/."
+ done
+ fi
+
+ # Fix perllocal.pod file collision
+ perl_delete_localpod
+
+ use python && python_optimize
+}
+
+src_test() {
+ # Known to fail with FEATURES=usersandbox (bug #657500):
+ if has usersandbox $FEATURES ; then
+ ewarn "You are emerging ${P} with 'usersandbox' enabled." \
+ "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ fi
+
+ emake check
+}
+
+pkg_postinst() {
+ if [[ -f "${EROOT}"/var/lib/rpm/Packages ]] ; then
+ einfo "RPM database found... Rebuilding database (may take a while)..."
+ "${EROOT}"/usr/bin/rpmdb --rebuilddb --root="${EROOT}/" || die
+ else
+ einfo "No RPM database found... Creating database..."
+ "${EROOT}"/usr/bin/rpmdb --initdb --root="${EROOT}/" || die
+ fi
+}