summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHector Martin <marcan@marcan.st>2017-11-26 01:51:22 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-11-26 01:51:45 +0100
commit57d39d4794da75dd7469590e964f83336f64acd1 (patch)
tree8d9dc59d2b8da2d415fdd2d7e9564fd9cd973c6f /app-arch
parentdev-tex/texamator: Fix HOMEPAGE (diff)
downloadgentoo-57d39d4794da75dd7469590e964f83336f64acd1.tar.gz
gentoo-57d39d4794da75dd7469590e964f83336f64acd1.tar.bz2
gentoo-57d39d4794da75dd7469590e964f83336f64acd1.zip
app-arch/unzip: Rev bump to add -DUSE_ICONV_MAPPING on USE=unicode
Closes: https://github.com/gentoo/gentoo/pull/6276 Package-Manager: Portage-2.3.16, Repoman-2.3.6 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unzip/Manifest6
-rw-r--r--app-arch/unzip/unzip-6.0_p21-r1.ebuild85
2 files changed, 88 insertions, 3 deletions
diff --git a/app-arch/unzip/Manifest b/app-arch/unzip/Manifest
index 8296fa70277c..23675a263bc6 100644
--- a/app-arch/unzip/Manifest
+++ b/app-arch/unzip/Manifest
@@ -1,3 +1,3 @@
-DIST unzip60.tar.gz 1376845 SHA256 036d96991646d0449ed0aa952e4fbe21b476ce994abc276e49d30e686708bd37 SHA512 0694e403ebc57b37218e00ec1a406cae5cc9c5b52b6798e0d4590840b6cdbf9ddc0d9471f67af783e960f8fa2e620394d51384257dca23d06bcd90224a80ce5d WHIRLPOOL eab32d6d0ab100d302b608658a3ae290d3dad4beddccebaf6cb6527102bb238f751ec6482dea68ae62474005de89f11f9e0cf1b1e12bee2ca5a2336a3c0c9808
-DIST unzip_6.0-20.debian.tar.xz 16680 SHA256 7ddfafb1a771ae8d6b4e25c5e31f22c717e0fe606b1bafadcdd574c01f671490 SHA512 7212cb110291581c2e465dc8ea5130eabffc4e0369d6245e8c26fa9d350bed904847d6e1191afaaa2d3fc23bd05fda7da80439d0c06b88f5331b01c9eff97fbe WHIRLPOOL ea5ebd5d95638ff8cd2e91eb77f5be544e33ac6fd478aa00c04da193cd3fad980c5ac1975dfedb2c242192cee6c4eee8bbaf3581299f6c3fa45faa639f0169fd
-DIST unzip_6.0-21.debian.tar.xz 17740 SHA256 8accd9d214630a366476437a3ec1842f2e057fdce16042a7b19ee569c33490a3 SHA512 f7bce4156ac13c34da3f991df3ae88b0db99b0810c7f8904ea3ac666a4cb2788d7182056f2bbd82d7519d0e0ee31a10af47bee08f360ceb859e5fbfc6e15ef36 WHIRLPOOL ce4d74e27ff27183989c680ef022328915c8ade5c1f12b39bcc1ee905dbd2fd3974cbb22da9bed40d8dc7a59de9ba768bfc6bb61d3bdd1b6f571945d06bf19f6
+DIST unzip60.tar.gz 1376845 BLAKE2B 5016d300b4452018a391f4ebc03c6960c068df400a0407c0c60bd7bb5ec5012031f916d8b204a6149ba291c2c35beba40d9b43c76fc093026e79471329ab0e47 SHA512 0694e403ebc57b37218e00ec1a406cae5cc9c5b52b6798e0d4590840b6cdbf9ddc0d9471f67af783e960f8fa2e620394d51384257dca23d06bcd90224a80ce5d
+DIST unzip_6.0-20.debian.tar.xz 16680 BLAKE2B 17ce9234ac485eab4e5188b555af31dcb0db577b199e0c58991ba7211c4c80edce52b72e89cc4d82b000b70bed1ac90262c0972507f28f054af2cebd0ca33b48 SHA512 7212cb110291581c2e465dc8ea5130eabffc4e0369d6245e8c26fa9d350bed904847d6e1191afaaa2d3fc23bd05fda7da80439d0c06b88f5331b01c9eff97fbe
+DIST unzip_6.0-21.debian.tar.xz 17740 BLAKE2B 098a84e5b05f819f9c8c6a6656fdb2359dfb5b93f63444e55347e0bef9735fa48bf1631a658a2cb6d0c604e7e740e47b57910d251b74e5df7c8b9468acfe55f4 SHA512 f7bce4156ac13c34da3f991df3ae88b0db99b0810c7f8904ea3ac666a4cb2788d7182056f2bbd82d7519d0e0ee31a10af47bee08f360ceb859e5fbfc6e15ef36
diff --git a/app-arch/unzip/unzip-6.0_p21-r1.ebuild b/app-arch/unzip/unzip-6.0_p21-r1.ebuild
new file mode 100644
index 000000000000..59771d0d1a70
--- /dev/null
+++ b/app-arch/unzip/unzip-6.0_p21-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_PV="${PV//.}"
+MY_PV="${MY_PV%_p*}"
+MY_P="${PN}${MY_PV}"
+
+DESCRIPTION="unzipper for pkzip-compressed files"
+HOMEPAGE="http://www.info-zip.org/"
+SRC_URI="mirror://sourceforge/infozip/${MY_P}.tar.gz
+ mirror://debian/pool/main/u/${PN}/${PN}_${PV/_p/-}.debian.tar.xz"
+
+LICENSE="Info-ZIP"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="bzip2 natspec unicode"
+
+DEPEND="bzip2? ( app-arch/bzip2 )
+ natspec? ( dev-libs/libnatspec )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ local deb="${WORKDIR}"/debian/patches
+ rm "${deb}"/02-this-is-debian-unzip.patch || die
+ eapply "${deb}"/*.patch
+
+ eapply "${FILESDIR}"/${PN}-6.0-no-exec-stack.patch
+ use natspec && eapply "${FILESDIR}/${PN}-6.0-natspec.patch" #275244
+ sed -i -r \
+ -e '/^CFLAGS/d' \
+ -e '/CFLAGS/s:-O[0-9]?:$(CFLAGS) $(CPPFLAGS):' \
+ -e '/^STRIP/s:=.*:=true:' \
+ -e "s:\<CC *= *\"?g?cc2?\"?\>:CC=\"$(tc-getCC)\":" \
+ -e "s:\<LD *= *\"?(g?cc2?|ld)\"?\>:LD=\"$(tc-getCC)\":" \
+ -e "s:\<AS *= *\"?(g?cc2?|as)\"?\>:AS=\"$(tc-getCC)\":" \
+ -e 's:LF2 = -s:LF2 = :' \
+ -e 's:LF = :LF = $(LDFLAGS) :' \
+ -e 's:SL = :SL = $(LDFLAGS) :' \
+ -e 's:FL = :FL = $(LDFLAGS) :' \
+ -e "/^#L_BZ2/s:^$(use bzip2 && echo .)::" \
+ -e 's:$(AS) :$(AS) $(ASFLAGS) :g' \
+ unix/Makefile \
+ || die "sed unix/Makefile failed"
+
+ # Delete bundled code to make sure we don't use it.
+ rm -r bzip2 || die
+
+ eapply_user
+}
+
+src_configure() {
+ case ${CHOST} in
+ i?86*-*linux*) TARGET="linux_asm" ;;
+ *linux*) TARGET="linux_noasm" ;;
+ i?86*-*bsd* | \
+ i?86*-dragonfly*) TARGET="freebsd" ;; # mislabelled bsd with x86 asm
+ *bsd* | *dragonfly*) TARGET="bsd" ;;
+ *-darwin*) TARGET="macosx" ;;
+ *-cygwin*) TARGET="cygwin" ;;
+ *) die "Unknown target; please update the ebuild to handle ${CHOST} " ;;
+ esac
+
+ [[ ${CHOST} == *linux* ]] && append-cppflags -DNO_LCHMOD
+ use bzip2 && append-cppflags -DUSE_BZIP2
+ use unicode && append-cppflags -DUNICODE_SUPPORT -DUNICODE_WCHAR -DUTF8_MAYBE_NATIVE -DUSE_ICONV_MAPPING
+ append-cppflags -DLARGE_FILE_SUPPORT #281473
+}
+
+src_compile() {
+ ASFLAGS="${ASFLAGS} $(get_abi_var CFLAGS)" \
+ emake -f unix/Makefile ${TARGET}
+}
+
+src_install() {
+ dobin unzip funzip unzipsfx unix/zipgrep
+ dosym unzip /usr/bin/zipinfo
+ doman man/*.1
+ dodoc BUGS History* README ToDo WHERE
+}