summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2015-12-23 16:10:10 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2015-12-23 16:10:10 +0200
commit913bc0bf8d7b1be5a8a8acd183eb79635382d3a3 (patch)
tree7b0a4540165f701791e3d1c42219a94d01a838dc /app-arch
parentdev-python/pyscard: version bump (diff)
downloadgentoo-913bc0bf8d7b1be5a8a8acd183eb79635382d3a3.tar.gz
gentoo-913bc0bf8d7b1be5a8a8acd183eb79635382d3a3.tar.bz2
gentoo-913bc0bf8d7b1be5a8a8acd183eb79635382d3a3.zip
app-arch/createrepo: version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/createrepo/Manifest1
-rw-r--r--app-arch/createrepo/createrepo-0.10.4.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-arch/createrepo/Manifest b/app-arch/createrepo/Manifest
index 8c291450f3a6..fdfcb5831da6 100644
--- a/app-arch/createrepo/Manifest
+++ b/app-arch/createrepo/Manifest
@@ -1,2 +1,3 @@
DIST createrepo-0.10.3.tar.gz 66004 SHA256 cd54621bef94c4a5ebffb5f19382050452d3e69763d2db4121c5d3881509ea6d SHA512 9e56625361dbc54667b42a4a8e84f46fd80dcb8d92ec9ff8532107981550612f946438061cc00b14c02f45aad18b33085bb0511a200715ba6d7c019785604a6e WHIRLPOOL 35de55956d7a69d6e7e5a32753336fc7808101330bb635e0712a06a76f7c5bd506b7cbaf0c728c099afe6a5927ad315e26ef44ce5cb57f6a9bb512dcf0af78df
+DIST createrepo-0.10.4.tar.gz 71186 SHA256 f850504a3ec7e556aaaa626d487e8b0def84ffea666fd30774cbbd575c128261 SHA512 28858d7d886e1132d001bb1bd847657502eb132133e39a4d19a4c8a080728c6b6f344283bc6ee21ce8def5b7980cbca7ed78299adeb71ce1012751268f6740ec WHIRLPOOL bd75e04ac4b04cb32d9359debff0413352abbddd7ea248a401eea353cb6fccbaa9d9a79e15ac2e81cd3e0d56fbd0f37b25f44c5cd94238ddf4a8cb9f6277a774
DIST createrepo-0.9.9-head.patch.bz2 14380 SHA256 74bdaea63c5f72d8814b0be5bc4b497188c8bd7c10fc3d66b6fd4058f98b58b8 SHA512 6d5e970e1489cef85cebedc3805bb1496c743c361b9bdda3d8df290f8e588d7d960272cf3c18e9c48fcdaf6a003b784a87aaea218da1ad68bf77446600980554 WHIRLPOOL 571319be8e0a7a559aa941046ea098e197f539d5156df12f3ac5ad87b133dbd7fc844ad208b7163110f8393a06eeb5c3a2fca2d09c870b3b59f457c6cb52634a
diff --git a/app-arch/createrepo/createrepo-0.10.4.ebuild b/app-arch/createrepo/createrepo-0.10.4.ebuild
new file mode 100644
index 000000000000..afe57b3a0db7
--- /dev/null
+++ b/app-arch/createrepo/createrepo-0.10.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='xml'
+
+inherit python-single-r1 bash-completion-r1 eutils
+
+DESCRIPTION="Creates a common rpm-metadata repository"
+HOMEPAGE="http://createrepo.baseurl.org/"
+SRC_URI="http://createrepo.baseurl.org/download/${P}.tar.gz
+ https://dev.gentoo.org/~pacho/maintainer-needed/${PN}-0.9.9-head.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/urlgrabber-2.9.0[${PYTHON_USEDEP}]
+ >=app-arch/rpm-4.1.1[python,${PYTHON_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ >=app-arch/deltarpm-3.6_pre20110223[python,${PYTHON_USEDEP}]
+ dev-python/pyliblzma[${PYTHON_USEDEP}]
+ >=sys-apps/yum-3.4.3
+ ${PYTHON_DEPS}"
+DEPEND="${PYTHON_DEPS}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ python_export PYTHON_SITEDIR
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.10.3-ten-changelog-limit.patch"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${ED}" \
+ PYTHON=true \
+ compdir="$(get_bashcompdir)" \
+ PKGDIR="${PYTHON_SITEDIR}/${PN}"
+ dodoc ChangeLog README
+ python_fix_shebang "${ED}"
+ python_optimize
+ python_optimize "${ED}/usr/share/createrepo"
+}