summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-02-16 18:14:00 -0500
committerMike Frysinger <vapier@gentoo.org>2017-02-16 18:44:48 -0500
commit9824dadc490f29b6fe004577b94cba92162d545e (patch)
tree8115a31bfcbb0da1fb4304a716427864428923ca /app-arch
parentapp-arch/pixz: use default src_{compile,install} targets (diff)
downloadgentoo-9824dadc490f29b6fe004577b94cba92162d545e.tar.gz
gentoo-9824dadc490f29b6fe004577b94cba92162d545e.tar.bz2
gentoo-9824dadc490f29b6fe004577b94cba92162d545e.zip
app-arch/pixz: switch to release tarballs
Upstream provides releases with generated autotools, so switch to that to speed up the build.
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pixz/Manifest2
-rw-r--r--app-arch/pixz/pixz-1.0.6.ebuild12
-rw-r--r--app-arch/pixz/pixz-9999.ebuild12
3 files changed, 13 insertions, 13 deletions
diff --git a/app-arch/pixz/Manifest b/app-arch/pixz/Manifest
index fffe792998ec..3fe12b293cca 100644
--- a/app-arch/pixz/Manifest
+++ b/app-arch/pixz/Manifest
@@ -1 +1 @@
-DIST pixz-1.0.6.tar.gz 27603 SHA256 ebde85148e927ed96abaeb9ab2166435c78d31e7c6b2847e8c8d6249b17f1b60 SHA512 432b4714501e4de53d5e4a9d91244cdf9b19cd3ef568d750e630cca16c91644073da6ff2ad676004e70a0a09b18dfdb9d6592420da47f0da3de64ec0757da2f7 WHIRLPOOL c796de23e0a0d78e28a03597202aa9730a2d57fa11942f705b726c48a1b42d9c7580c0efb11133fad7e461b937d1af6760f648fbf6d9a0196486753104ad161e
+DIST pixz-1.0.6.tar.xz 119516 SHA256 02c50746b134fa1b1aae41fcc314d7c6f1919b3d48bcdea01bf11769f83f72e8 SHA512 361a8d8b736c350e4e3fd19b5d36777129a087eb81439d05edc08f9378938583bef8fc70e440ffd22efb6dad1f6494c6c3e532d7dd1ab12c9350b6078aa993d7 WHIRLPOOL cc5849746665a07e41e2f670410f00428a7ef9390e4dea83f1797efe51b1e73324002d68d74bf9c659affdcfc597ce45442da5f548d3326eb48af9fc6ce033c4
diff --git a/app-arch/pixz/pixz-1.0.6.ebuild b/app-arch/pixz/pixz-1.0.6.ebuild
index 7caca229a63e..fe9d1a813ca3 100644
--- a/app-arch/pixz/pixz-1.0.6.ebuild
+++ b/app-arch/pixz/pixz-1.0.6.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit flag-o-matic autotools
+inherit flag-o-matic
DESCRIPTION="Parallel Indexed XZ compressor"
HOMEPAGE="https://github.com/vasi/pixz"
@@ -16,21 +16,21 @@ LIB_DEPEND=">=app-arch/libarchive-2.8:=[static-libs(+)]
>=app-arch/xz-utils-5[static-libs(+)]"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )
- app-text/asciidoc"
+ static? ( ${LIB_DEPEND} )"
+[[ ${PV} == "9999" ]] && DEPEND+=" app-text/asciidoc"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/vasi/${PN}.git"
- inherit git-r3
+ inherit git-r3 autotools
KEYWORDS=""
else
- SRC_URI="https://github.com/vasi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/vasi/pixz/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~x86"
fi
src_prepare() {
default
- eautoreconf
+ [[ ${PV} == "9999" ]] && eautoreconf
}
src_configure() {
diff --git a/app-arch/pixz/pixz-9999.ebuild b/app-arch/pixz/pixz-9999.ebuild
index 7caca229a63e..fe9d1a813ca3 100644
--- a/app-arch/pixz/pixz-9999.ebuild
+++ b/app-arch/pixz/pixz-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit flag-o-matic autotools
+inherit flag-o-matic
DESCRIPTION="Parallel Indexed XZ compressor"
HOMEPAGE="https://github.com/vasi/pixz"
@@ -16,21 +16,21 @@ LIB_DEPEND=">=app-arch/libarchive-2.8:=[static-libs(+)]
>=app-arch/xz-utils-5[static-libs(+)]"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )
- app-text/asciidoc"
+ static? ( ${LIB_DEPEND} )"
+[[ ${PV} == "9999" ]] && DEPEND+=" app-text/asciidoc"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/vasi/${PN}.git"
- inherit git-r3
+ inherit git-r3 autotools
KEYWORDS=""
else
- SRC_URI="https://github.com/vasi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/vasi/pixz/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~x86"
fi
src_prepare() {
default
- eautoreconf
+ [[ ${PV} == "9999" ]] && eautoreconf
}
src_configure() {