summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2015-12-19 23:39:08 +0100
committerSebastian Pipping <sping@gentoo.org>2015-12-19 23:44:14 +0100
commita13b62985794eea5611c6a765d6b585e5807dd51 (patch)
treeb84a1744a7af00010aceebdbd45de4c2a5a0d251 /app-arch
parentdev-libs/libnl: arm stable, bug #568052 (diff)
downloadgentoo-a13b62985794eea5611c6a765d6b585e5807dd51.tar.gz
gentoo-a13b62985794eea5611c6a765d6b585e5807dd51.tar.bz2
gentoo-a13b62985794eea5611c6a765d6b585e5807dd51.zip
app-arch/file-roller: Apply bugfix patch accepted upstream
https://bugzilla.gnome.org/show_bug.cgi?id=757793 Package-Manager: portage-2.2.26
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/file-roller/file-roller-3.16.4-r1.ebuild94
-rw-r--r--app-arch/file-roller/files/file-roller-3.16.4-bug-757793.patch25
2 files changed, 119 insertions, 0 deletions
diff --git a/app-arch/file-roller/file-roller-3.16.4-r1.ebuild b/app-arch/file-roller/file-roller-3.16.4-r1.ebuild
new file mode 100644
index 000000000000..d58e1fe5d833
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.16.4-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 readme.gentoo
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="nautilus packagekit"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.13.2:3
+ >=x11-libs/libnotify-0.4.3:=
+ sys-apps/file
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ nautilus? ( >=gnome-base/nautilus-3 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.40.0
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -f "${FILESDIR}"/3.6.0-packages.match data/packages.match || die
+ gnome2_src_prepare
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=757793
+ epatch "${FILESDIR}"/${P}-bug-757793.patch
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+ # --disable-debug because enabling it adds -O0 to CFLAGS
+ gnome2_src_configure \
+ --disable-run-in-place \
+ --disable-static \
+ --disable-debug \
+ --enable-magic \
+ --enable-libarchive \
+ $(use_enable nautilus nautilus-actions) \
+ $(use_enable packagekit)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/app-arch/file-roller/files/file-roller-3.16.4-bug-757793.patch b/app-arch/file-roller/files/file-roller-3.16.4-bug-757793.patch
new file mode 100644
index 000000000000..9256c1d6935e
--- /dev/null
+++ b/app-arch/file-roller/files/file-roller-3.16.4-bug-757793.patch
@@ -0,0 +1,25 @@
+From b9308bac8f93c047d0ce7a3b52e9b5f09adf2c86 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sun, 6 Dec 2015 15:23:31 +0100
+Subject: [PATCH] Stop mis-treating p7zip 15.09 as pre-4.55 (#757793)
+
+---
+ src/fr-command-7z.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/fr-command-7z.c b/src/fr-command-7z.c
+index fc33d4d..1befbf5 100644
+--- a/src/fr-command-7z.c
++++ b/src/fr-command-7z.c
+@@ -98,7 +98,7 @@ list__process_line (char *line,
+ strncpy (version, ver_start, ver_len);
+ version[ver_len] = 0;
+
+- if (strcmp (version, "4.55") < 0)
++ if ((strcmp (version, "4.55") < 0) && (ver_len > 1) && (version[1] == '.'))
+ self->old_style = TRUE;
+ else
+ self->old_style = FALSE;
+--
+2.6.3
+