summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2017-03-21 16:28:25 +0500
committerPatrice Clement <monsieurp@gentoo.org>2017-03-22 12:22:09 +0100
commitdb85f6bd42f42c0a1aec62ae080faf3fafaf6598 (patch)
treeaa576b5621d65c8f9b963531bb38a2c4463f1c9e /app-arch
parentdev-vcs/subversion: add cygwin support (diff)
downloadgentoo-db85f6bd42f42c0a1aec62ae080faf3fafaf6598.tar.gz
gentoo-db85f6bd42f42c0a1aec62ae080faf3fafaf6598.tar.bz2
gentoo-db85f6bd42f42c0a1aec62ae080faf3fafaf6598.zip
app-arch/qpress: new package.
This package required as runtime dependency for dev-db/percona-xtrabackup. Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4270
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/qpress/Manifest1
-rw-r--r--app-arch/qpress/files/makefile6
-rw-r--r--app-arch/qpress/metadata.xml15
-rw-r--r--app-arch/qpress/qpress-1.1.ebuild26
4 files changed, 48 insertions, 0 deletions
diff --git a/app-arch/qpress/Manifest b/app-arch/qpress/Manifest
new file mode 100644
index 000000000000..1a77e8d1d802
--- /dev/null
+++ b/app-arch/qpress/Manifest
@@ -0,0 +1 @@
+DIST qpress-11-source.zip 26998 SHA256 4bb66b1383bbc4c5490eec6088d37109e11205fb9f94ccd04cb84ec069829633 SHA512 986754cca8bb2cdcfc7e197f7e123c6b2da90db840642a6385f14613f49f7ec6b2c18944838405fe35d5382d71fcd5d69050a036dda4c5de2e588d144e16ea6b WHIRLPOOL b8ee4274da850091dfc2be520870530f9d1208f1791d5649df6856dfa2e7e6a500e1cc9c08cbcb64160f4a40137676af6d1820b862112e878f191da21d7f60fd
diff --git a/app-arch/qpress/files/makefile b/app-arch/qpress/files/makefile
new file mode 100644
index 000000000000..63c1f91b3943
--- /dev/null
+++ b/app-arch/qpress/files/makefile
@@ -0,0 +1,6 @@
+CXX ?= g++
+CXXFLAGS ?= -O3
+LIBS=-lpthread
+
+qpress:
+ $(CXX) $(CXXFLAGS) qpress.cpp aio.cpp quicklz.c utilities.cpp -o $@ $(LIBS)
diff --git a/app-arch/qpress/metadata.xml b/app-arch/qpress/metadata.xml
new file mode 100644
index 000000000000..f326e2195f06
--- /dev/null
+++ b/app-arch/qpress/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ A portable file archiver using QuickLZ algorithm.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-arch/qpress/qpress-1.1.ebuild b/app-arch/qpress/qpress-1.1.ebuild
new file mode 100644
index 000000000000..e7787c7973a5
--- /dev/null
+++ b/app-arch/qpress/qpress-1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A portable file archiver using QuickLZ algorithm"
+HOMEPAGE="http://www.quicklz.com/"
+SRC_URI="http://www.quicklz.com/${PN}-${PV/./}-source.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # Fix compilation with newer gcc
+ sed -i '1i #include <unistd.h>' qpress.cpp || die
+ cp "${FILESDIR}/makefile" "${S}" || die
+}
+
+src_install() {
+ dobin ${PN}
+}