summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-04-03 11:39:42 +0100
committerSam James <sam@gentoo.org>2021-04-09 20:42:22 +0000
commitf3a6d0085159620af4f4bb8512f0f2d2af159211 (patch)
treec77932760c692fecdf03b55853f30e74234e1afa /app-arch
parentapp-arch/makeself: Adopt package (diff)
downloadgentoo-f3a6d0085159620af4f4bb8512f0f2d2af159211.tar.gz
gentoo-f3a6d0085159620af4f4bb8512f0f2d2af159211.tar.bz2
gentoo-f3a6d0085159620af4f4bb8512f0f2d2af159211.zip
app-arch/makeself: Bump to 2.4.3
* Bump to EAPI=7 * Fix LICENSE * Remove useless inherits * Remove makeself-unpack script that no longer works * Use optfeature for extra compression methods Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/20243 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/makeself/Manifest1
-rw-r--r--app-arch/makeself/makeself-2.4.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-arch/makeself/Manifest b/app-arch/makeself/Manifest
index ba4d86418fe3..c7e58feec235 100644
--- a/app-arch/makeself/Manifest
+++ b/app-arch/makeself/Manifest
@@ -1 +1,2 @@
+DIST makeself-2.4.3.tar.gz 32613 BLAKE2B 2295b6d47a8105f2b495260abb0c9ae85875c821d0291a19b5af894c1cef669f338c4e10de8128fe38008e7e08079d1f29949884f202cab680c7fd62e2f00dd9 SHA512 d404c7920c7f69ae29c7168bcf76806b6e2aae2e8916bb7feed998d031ce8b2cd205b83ad960a90b01189c97f9242eb3ef574194ba3ee51c605fe99dafbd6c13
DIST release-2.2.0.tar.gz 21640 BLAKE2B 32b06157829864918d225a136043a5c9b7c6c543351e981c0e3cdce84cbbe4c52f00870bb04d29bfd79e715c1c708b51cc9958d495a9633afb9a8d342601c20d SHA512 11cd536baed2d56405103f18a8318a202092755a74baf10730aa58dc57032e327697b1c7f76bf9bf438927093ba9ac467ffa0c4564c7f6b1d3b2b3936f34fa73
diff --git a/app-arch/makeself/makeself-2.4.3.ebuild b/app-arch/makeself/makeself-2.4.3.ebuild
new file mode 100644
index 000000000000..a46a9d81b0c7
--- /dev/null
+++ b/app-arch/makeself/makeself-2.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature
+
+DESCRIPTION="Shell script that generates a self-extractible tar.gz"
+HOMEPAGE="http://www.megastep.org/makeself/"
+SRC_URI="https://github.com/megastep/makeself/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ default
+ rm Makefile || die
+}
+
+src_install() {
+ dobin makeself-header.sh makeself.sh
+ dosym makeself.sh /usr/bin/makeself
+ doman makeself.1
+ dodoc README.md makeself.lsm
+}
+
+pkg_postinst() {
+ optfeature "lz4 support" app-arch/lz4
+ optfeature "lzop support" app-arch/lzop
+ optfeature "pbzip2 support" app-arch/pbzip2
+ optfeature "pigz support" app-arch/pigz
+ optfeature "zstd support" app-arch/zstd
+
+ # Also bzip2 and xz are supported but they are in @system.
+}