summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/backintime/backintime-1.0.24-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/backintime/backintime-1.0.24-r2.ebuild')
-rw-r--r--app-backup/backintime/backintime-1.0.24-r2.ebuild98
1 files changed, 98 insertions, 0 deletions
diff --git a/app-backup/backintime/backintime-1.0.24-r2.ebuild b/app-backup/backintime/backintime-1.0.24-r2.ebuild
new file mode 100644
index 000000000000..c6d232e9aed2
--- /dev/null
+++ b/app-backup/backintime/backintime-1.0.24-r2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="A simple backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
+HOMEPAGE="http://backintime.le-web.org/"
+SRC_URI="http://${PN}.le-web.org/wp-content/uploads/2009/03/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kde gnome"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/notify-python[${PYTHON_USEDEP}]
+ net-misc/openssh
+ net-misc/rsync[xattr,acl]
+ kde? (
+ >=kde-base/kdelibs-4
+ kde-base/pykde4[${PYTHON_USEDEP}]
+ kde-apps/kompare:4
+ kde-apps/kdesu:4
+ )
+ gnome? (
+ gnome-base/libglade
+ dev-util/meld
+ gnome-base/gnome-session
+ dev-python/gnome-vfs-python
+ dev-python/libgnome-python
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ x11-libs/gksu
+ )"
+
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-dont-install-license.patch
+ epatch "${FILESDIR}"/${PN}-1.0.4-fix-configure-warning.diff
+
+ #fix doc install location
+ sed -i "s:/doc/kde4/HTML/:/doc/HTML/:g" kde4/Makefile.template || die
+ sed -i "s:/doc/backintime:/doc/${PF}:g" common/Makefile.template || die
+
+ cp "${FILESDIR}"/backintime-1.0.4-kde4-root.desktop \
+ kde4/backintime-kde4-root.desktop || die
+
+ #bug 482106
+ epatch "${FILESDIR}"/${P}-wrapper.patch
+ sed -e "s:^python2 :${PYTHON} :" \
+ -e "s:APP_PATH=\"/usr:APP_PATH=\"${EPREFIX}/usr:" \
+ -i kde4/backintime-kde4 gnome/backintime-gnome \
+ common/backintime || die
+
+ backintime_variants="common $(usex gnome gnome '') $(usex kde kde4 '')"
+ backintime_run() {
+ local variant
+ for variant in ${backintime_variants} ; do
+ einfo "$variant: run \"$@\""
+ pushd "${S}"/${variant} || die
+ "${@}" || die
+ popd
+ done
+ }
+
+ if [ -n ${LINGUAS+x} ] ; then
+ cd common/po || die
+ for po in *.po ; do
+ if ! has ${po/.po} ${LINGUAS} ; then
+ rm ${po} || die
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ backintime_run econf
+}
+
+src_compile() {
+ backintime_run emake
+}
+
+src_install() {
+ backintime_run emake DESTDIR="${D}" install
+ python_optimize "${D}"
+}