summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/backup-manager
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/backup-manager')
-rw-r--r--app-backup/backup-manager/Manifest2
-rw-r--r--app-backup/backup-manager/backup-manager-0.7.10.1-r1.ebuild50
-rw-r--r--app-backup/backup-manager/backup-manager-0.7.10.1-r2.ebuild51
-rw-r--r--app-backup/backup-manager/backup-manager-0.7.5.ebuild45
-rw-r--r--app-backup/backup-manager/files/Makefile-fix.diff25
-rw-r--r--app-backup/backup-manager/files/backup-manager-0.7.10-Fix-POD-syntax.patch30
-rw-r--r--app-backup/backup-manager/files/backup-manager-0.7.9-parallel_install.patch20
-rw-r--r--app-backup/backup-manager/metadata.xml13
8 files changed, 236 insertions, 0 deletions
diff --git a/app-backup/backup-manager/Manifest b/app-backup/backup-manager/Manifest
new file mode 100644
index 000000000000..33784c036aa2
--- /dev/null
+++ b/app-backup/backup-manager/Manifest
@@ -0,0 +1,2 @@
+DIST Backup-Manager-0.7.10.1.tar.gz 150963 SHA256 16994520d3fded41e166d17c946405dd192acf960603044aa6c915465e78d41f SHA512 8c51e8150b0a67c416bcba6291b85f2bb2dfd79521f4e0f8a2de47c5903dafbebde4048224cbecf92fc09b3a6ac431fab51434ccced81cf2fbfdd24482432618 WHIRLPOOL e1fb4913038dd25fc39dd0663cb434b3cadcb855c704fa3825ec2484a965f5b6b6ad1cf4e20132fa487b84c082a5883641fa9ad7d2b01f44f58d2d13003bf5c6
+DIST backup-manager-0.7.5.tar.gz 159855 SHA256 a7aa04ebec5b8a80d5e75d48121092afb969e1efb252b1ffdbcd28b04225e55a SHA512 3101e695d79c429e5a415a174c12b6217495aaefc0b44ee870bb492eea75ce07dacb766a45c60268a0f7da798d51b46f6d91f33b9d545360f09b92b61329bcef WHIRLPOOL 366e205c15084231fad81af9cbcebca34e7d3637476ba7046dc840d3f54c110469588ddc939c112525bac8d4764a7be2097c1b218f59af752af453091ff8299f
diff --git a/app-backup/backup-manager/backup-manager-0.7.10.1-r1.ebuild b/app-backup/backup-manager/backup-manager-0.7.10.1-r1.ebuild
new file mode 100644
index 000000000000..5ee25a3bdea2
--- /dev/null
+++ b/app-backup/backup-manager/backup-manager-0.7.10.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+MY_P=Backup-Manager-${PV}
+DESCRIPTION="Backup Manager is a command line backup tool for GNU/Linux"
+HOMEPAGE="http://www.backup-manager.org/"
+SRC_URI="http://www.backup-manager.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc s3"
+
+DEPEND="dev-lang/perl
+ sys-devel/gettext"
+
+RDEPEND="${DEPEND}
+ >=sys-apps/findutils-4.3.0
+ s3? ( dev-perl/Net-Amazon-S3
+ dev-perl/File-Slurp )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i "/^PERL5DIR/s/sitelib/vendorlib/" Makefile \
+ || die "Makefile sed failed"
+ sed -i '/^prefix=/s/$(PREFIX)/usr/' po/Makefile \
+ || die "po Makefile sed failed"
+ epatch "${FILESDIR}"/${PN}-0.7.9-parallel_install.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use doc && dodoc doc/user-guide.txt
+}
+
+pkg_postinst() {
+ elog "After installing,"
+ elog "copy ${ROOT%/}/usr/share/backup-manager/backup-manager.conf.tpl to"
+ elog "/etc/backup-manager.conf and customize it for your environment."
+ elog "You could also set-up your cron for daily or weekly backup."
+
+ ewarn "New configuration keys may have been defined."
+ ewarn "Please check the docs for info"
+}
diff --git a/app-backup/backup-manager/backup-manager-0.7.10.1-r2.ebuild b/app-backup/backup-manager/backup-manager-0.7.10.1-r2.ebuild
new file mode 100644
index 000000000000..1ccd1db2a266
--- /dev/null
+++ b/app-backup/backup-manager/backup-manager-0.7.10.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P=Backup-Manager-${PV}
+DESCRIPTION="Backup Manager is a command line backup tool for GNU/Linux"
+HOMEPAGE="http://www.backup-manager.org/"
+SRC_URI="http://www.backup-manager.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc s3"
+
+DEPEND="dev-lang/perl
+ sys-devel/gettext"
+
+RDEPEND="${DEPEND}
+ >=sys-apps/findutils-4.3.0
+ s3? ( dev-perl/Net-Amazon-S3
+ dev-perl/File-Slurp )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i "/^PERL5DIR/s/sitelib/vendorlib/" Makefile \
+ || die "Makefile sed failed"
+ sed -i '/^prefix=/s/$(PREFIX)/usr/' po/Makefile \
+ || die "po Makefile sed failed"
+ epatch "${FILESDIR}"/${PN}-0.7.9-parallel_install.patch
+ epatch "${FILESDIR}"/${PN}-0.7.10-Fix-POD-syntax.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use doc && dodoc doc/user-guide.txt
+}
+
+pkg_postinst() {
+ elog "After installing,"
+ elog "copy ${ROOT%/}/usr/share/backup-manager/backup-manager.conf.tpl to"
+ elog "/etc/backup-manager.conf and customize it for your environment."
+ elog "You could also set-up your cron for daily or weekly backup."
+
+ ewarn "New configuration keys may have been defined."
+ ewarn "Please check the docs for info"
+}
diff --git a/app-backup/backup-manager/backup-manager-0.7.5.ebuild b/app-backup/backup-manager/backup-manager-0.7.5.ebuild
new file mode 100644
index 000000000000..8c3b11aad6ce
--- /dev/null
+++ b/app-backup/backup-manager/backup-manager-0.7.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Backup Manager is a command line backup tool for GNU/Linux"
+HOMEPAGE="http://www.backup-manager.org/"
+SRC_URI="http://www.backup-manager.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+DEPEND="dev-lang/perl
+ sys-devel/gettext"
+
+RDEPEND="${DEPEND}
+ >=sys-apps/findutils-4.3.0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/Makefile-fix.diff
+}
+
+src_compile() {
+ # doing nothing, cause a call to make would start make install
+ true
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ use doc && dodoc doc/user-guide.txt
+}
+
+pkg_postinst() {
+ elog "After installing,"
+ elog "copy ${ROOT%/}/usr/share/backup-manager/backup-manager.conf.tpl to"
+ elog "/etc/backup-manager.conf and customize it for your environment."
+ elog "You could also set-up your cron for daily or weekly backup."
+ ebeep 3
+ ewarn "New configuration keys have been defined. Please check the docs for info"
+}
diff --git a/app-backup/backup-manager/files/Makefile-fix.diff b/app-backup/backup-manager/files/Makefile-fix.diff
new file mode 100644
index 000000000000..86ebee845d4f
--- /dev/null
+++ b/app-backup/backup-manager/files/Makefile-fix.diff
@@ -0,0 +1,25 @@
+diff -urN backup-manager-0.7.2/Makefile backup-manager-0.7.2-modified/Makefile
+--- backup-manager-0.7.2/Makefile 2006-03-12 20:20:34.000000000 +0900
++++ backup-manager-0.7.2-modified/Makefile 2006-03-18 18:06:49.000000000 +0900
+@@ -78,8 +78,8 @@
+ # Installing the man pages.
+ install_man: man/backup-manager-upload.8
+ @echo -e "\n*** Installing man pages ***\n"
+- install -d /usr/share/man/man8/
+- install --owner=root --group=root --mode=0644 man/*.8 /usr/share/man/man8/
++ install -d $(DESTDIR)/usr/share/man/man8/
++ install --owner=root --group=root --mode=0644 man/*.8 $(DESTDIR)/usr/share/man/man8/
+
+ docs:
+ make -C doc all
+--- backup-manager-0.7.2/Makefile.orig 2006-06-06 15:25:05.000000000 +0100
++++ backup-manager-0.7.2/Makefile 2006-06-06 15:25:25.000000000 +0100
+@@ -1,7 +1,7 @@
+ DESTDIR?=
+
+ # For the backup-manager package
+-PERL5DIR=$(DESTDIR)/usr/share/perl5
++PERL5DIR=$(DESTDIR)/usr/lib/perl5/vendor_perl
+ LIBDIR=$(DESTDIR)/usr/share/backup-manager
+ CONTRIB=$(LIBDIR)/contrib
+ SHAREDIR=$(DESTDIR)/usr/share/backup-manager
diff --git a/app-backup/backup-manager/files/backup-manager-0.7.10-Fix-POD-syntax.patch b/app-backup/backup-manager/files/backup-manager-0.7.10-Fix-POD-syntax.patch
new file mode 100644
index 000000000000..61ac590241e2
--- /dev/null
+++ b/app-backup/backup-manager/files/backup-manager-0.7.10-Fix-POD-syntax.patch
@@ -0,0 +1,30 @@
+From 808f397dbc76d61e6e29c661585afeb6ba9c41a2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
+Date: Sat, 20 Jul 2013 13:41:25 +0200
+Subject: [PATCH] Fix POD syntax
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+
+Signed-off-by: Petr Písař <ppisar@redhat.com>
+---
+ backup-manager-purge | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/backup-manager-purge b/backup-manager-purge
+index ce7a67f..c9a5f1c 100755
+--- a/backup-manager-purge
++++ b/backup-manager-purge
+@@ -53,6 +53,8 @@ than I<ttl> days will be outdated.
+
+ =head1 OPTIONAL ARGS
+
++=over 4
++
+ =item B<--files-from=>file
+
+ A file containing a list of archives to parse, one archive per line.
+--
+1.8.1.4
+
diff --git a/app-backup/backup-manager/files/backup-manager-0.7.9-parallel_install.patch b/app-backup/backup-manager/files/backup-manager-0.7.9-parallel_install.patch
new file mode 100644
index 000000000000..482346b6eb3a
--- /dev/null
+++ b/app-backup/backup-manager/files/backup-manager-0.7.9-parallel_install.patch
@@ -0,0 +1,20 @@
+--- Makefile.orig 2010-09-14 17:24:31.267313414 +0200
++++ Makefile 2010-09-14 17:24:36.395250687 +0200
+@@ -62,7 +62,7 @@
+
+ # Main build rule (we don't buid the docs as we don't know if debiandocs can be
+ # there) so the docs target has to be called manually by vendors.
+-build: manpages
++build: manpages po
+
+ # The backup-manager package
+ install: build install_lib install_bin install_contrib install_man install_po
+@@ -84,6 +84,8 @@
+ install --owner=root --group=root --mode=0644 $(DOCHTMLFILES) $(DOCHTMLDIR)
+
+ # The translation stuff
++po:
++ $(MAKE) -C po
+ install_po:
+ $(MAKE) -C po install
+
diff --git a/app-backup/backup-manager/metadata.xml b/app-backup/backup-manager/metadata.xml
new file mode 100644
index 000000000000..00cb68d43e38
--- /dev/null
+++ b/app-backup/backup-manager/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <herd>app-backup</herd>
+ <longdescription>command line backup tool, designed to help make daily archives of the file system. It can make archives in lots of open formats (tar, gzip, bzip2, lzma, dar, zip) and provides interesting features (such as network exports or CD/DVD automated-burning)</longdescription>
+ <use>
+ <flag name="s3">Support for backing up to the Amazon S3 system</flag>
+ </use>
+</pkgmetadata>