summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Fischl <github@fischl-online.de>2022-02-19 07:15:06 +0100
committerSam James <sam@gentoo.org>2022-02-23 03:58:11 +0000
commit60ae8cd8e9776e978f509da3a3cd50225b8ba8ad (patch)
tree0e1879dd51df2006019e242a925ac104caeeba9a /app-backup/burp
parentgui-apps/grim: update dependencies and install completions manually (diff)
downloadgentoo-60ae8cd8e9776e978f509da3a3cd50225b8ba8ad.tar.gz
gentoo-60ae8cd8e9776e978f509da3a3cd50225b8ba8ad.tar.bz2
gentoo-60ae8cd8e9776e978f509da3a3cd50225b8ba8ad.zip
app-backup/burp: bump 2.5.4 (masked)
Version 2.5.* is not meant for production according to upstream Signed-off-by: Anton Fischl <github@fischl-online.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup/burp')
-rw-r--r--app-backup/burp/Manifest1
-rw-r--r--app-backup/burp/burp-2.5.4.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/app-backup/burp/Manifest b/app-backup/burp/Manifest
index ecbb90691b22..1063852e4e23 100644
--- a/app-backup/burp/Manifest
+++ b/app-backup/burp/Manifest
@@ -1,3 +1,4 @@
DIST burp-2.2.18.tar.gz 632805 BLAKE2B 6106aa4bd96db035ad5893c2fe314537e620a67519295fdf99efaf2c5a639bedd15b4c8d95caa3daa3072dfac28a1ba7fd7bb4f949d9ea2b70bd13060a22f2c6 SHA512 beb14c61ace6d61b98a10fc4e6709eec9722e28990de862eef6a75984f9fbd0f903c5fe64d20ed84c95528a9889bc22618ba6d2318318cf5d515b35688db0a4d
DIST burp-2.3.36.tar.gz 619564 BLAKE2B 8f30fb8808c8a3167467ef0bcdc84cd7c2e885ee6a8aa285d96f9187aeb33eacb90fefe382ddb74bbabcfefde6faa9ac6125e3bf4a6eb9778b650e74e812991d SHA512 48b852aca8ccf0abd696b9434cb83c0447845192096d0f3f0c032c328dcc20314faf68db94fa14da72692327432b78eb3680e83b1e892dd30c9aa2f340838ee3
DIST burp-2.4.0.tar.gz 624032 BLAKE2B 4a1ff48236dc631dd6d545480a33af3cdf8020c3088f1ca09ab66ac5cec8128d262b9b991bf9e3229c80f75a4746d338073a0a43fdb67a2fe21a0fd4f243469d SHA512 ea81a12e54c6d88b702dd09dc4fa5a724d1e322bdfba2643c9312a9077c9edc63f6ca0f6cb3a6ebecb6ad9feb1cc26c114277b2308d9903f4abb0442a9be7c19
+DIST burp-2.5.4.tar.gz 625018 BLAKE2B 83cb8e48c616f527b2271c6ea5855a303f2925d3d0b83182afc64fe139676a4b1b98349d0ba0636613d3409f100417c4a36b7b1f24bc64bba329940d4587cd2b SHA512 b283e34e76a6887517d72c99deac5e0299efa07dd922d1275666683cc3ba4b040b97e5ce4840cb06025926ea616778811bf4c9c6f9c7564da5122900cdd7bad0
diff --git a/app-backup/burp/burp-2.5.4.ebuild b/app-backup/burp/burp-2.5.4.ebuild
new file mode 100644
index 000000000000..f43a92ad64bd
--- /dev/null
+++ b/app-backup/burp/burp-2.5.4.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="https://burp.grke.org/"
+SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl ipv6 test xattr"
+
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="acct-group/burp
+ acct-user/burp
+ dev-libs/uthash
+ dev-libs/openssl:0=
+ net-libs/librsync:=
+ sys-libs/ncurses:0=
+ sys-libs/libcap
+ sys-libs/zlib
+ virtual/libcrypt:=
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )"
+DEPEND="${COMMON_DEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )
+ test? ( dev-libs/check )"
+BDEPEND=">=sys-devel/autoconf-2.71
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ virtual/logger"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
+ "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
+ "${FILESDIR}"/${PN}-2.0.54-server_user.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --sysconfdir=/etc/burp
+ --enable-largefile
+ --runstatedir=/run
+ $(use_enable acl)
+ $(use_enable ipv6)
+ $(use_enable xattr)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # See https://github.com/grke/burp/issues/869
+ local -x CK_DEFAULT_TIMEOUT=10
+ default
+}
+
+src_install() {
+ default
+ keepdir /var/spool/burp
+ fowners -R root:${PN} /var/spool/burp
+ fperms 0770 /var/spool/burp
+
+ emake DESTDIR="${D}" install-configs
+ fowners -R root:${PN} /etc/burp
+ fperms 0750 /etc/burp
+ fperms 0640 /etc/burp/burp-server.conf
+ fperms 0750 /etc/burp/clientconfdir
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ elog "Burp ebuilds now support the autoupgrade mechanism in both"
+ elog "client and server mode. In both cases it is disabled by"
+ elog "default. You almost certainly do NOT want to enable it in"
+ elog "client mode because upgrades obtained this way will not be"
+ elog "managed by Portage."
+
+ if [[ ! -e ${EROOT}/etc/burp/CA/index.txt ]]; then
+ elog ""
+ elog "At first run burp server will generate DH parameters and SSL"
+ elog "certificates. You should adjust configuration before."
+ elog "Server configuration is located at"
+ elog ""
+ elog " ${EROOT}/etc/burp/burp-server.conf"
+ elog ""
+ fi
+
+ # According to PMS this can be a space-separated list of version
+ # numbers, even though in practice it is typically just one.
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
+ ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
+ ewarn "the server config file by default. If you use bedup, please"
+ ewarn "update your scripts to invoke it as"
+ ewarn ""
+ ewarn " bedup -c ${EROOT}/etc/burp/burp-server.conf"
+ ewarn ""
+ ewarn "Otherwise deduplication will not work!"
+ break
+ fi
+ done
+}