summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-05-12 00:35:27 -0400
committerTim Harder <radhermit@gentoo.org>2016-05-12 00:35:27 -0400
commit246007f2fee299ad09b2c5535ec97ebfd874983e (patch)
treec7282d7a210434dbc7c68b647fe03f370625f950 /app-backup/duplicity
parentdev-python/pycryptopp: version bump to 0.7.1 (diff)
downloadgentoo-246007f2fee299ad09b2c5535ec97ebfd874983e.tar.gz
gentoo-246007f2fee299ad09b2c5535ec97ebfd874983e.tar.bz2
gentoo-246007f2fee299ad09b2c5535ec97ebfd874983e.zip
app-backup/duplicity: version bump to 0.7.07.1
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-0.7.07.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 3c064751b4cb..ac244b30c318 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -3,3 +3,4 @@ DIST duplicity-0.6.23.tar.gz 1260261 SHA256 7a17f1e10395dedcf3204bc53925bb9dcbbf
DIST duplicity-0.6.24.tar.gz 1268175 SHA256 1d41d756638f55106f9501c3db94ccbc6568aa856ba531e07ed2cfb760b62450 SHA512 5bb783ef6ddbfa6672279287b01f44e33256829971e7b8bbe26d648d2c78d438018bddd977281b8a1ff7e5c1505a3b60fe03ecb5ba8022a597f9f952b2815273 WHIRLPOOL f42120cc403a987a9e5f747e1f7502059772f9c2fdb1afb92caa354676b7089736cd9524d08ef6677872a5019e17d2092513cc5544beed5fb0d80158742e1ebf
DIST duplicity-0.6.25.tar.gz 1269583 SHA256 ac44f44abc1c5fe775a49b77e722d238c0b3bbb105e083fd505e2dca8e2c1725 SHA512 17304e38990e0a34aa4bae9f2d12a99ece031ac048667fba27afbcc32e1fb8455a2672426e49edb543bd7e345dc74f784f34c26ec2e1651eb10ba479868e04a0 WHIRLPOOL 8af905551078e30529dd31bd7de8f783ec0875c57e9f4d93388c5e407e9aecd19c0d151d3eb4d718cb5ea4dd649bb835611604f5ee5ad33f04355846a406d39d
DIST duplicity-0.6.26.tar.gz 1270436 SHA256 8bef8a5d805b79ae177e54d42152238bce1b2aaf9ad32e03a2c3a20cbd4e074a SHA512 0cd02984eda99c81a30c9ac9926c41df0597f8f287a3e8ccd7d6fb9d420159028112be6b3fc8acf9b413940c07d0e754b2a509b6bca52965d2c333d4bcec8689 WHIRLPOOL 873b9fc9e035ed31cef996ace747c6a97b9434b50945578b019627c94e8eb7ba0861909e74b95db143ddb50dfdb23241a3ddfe712a97e0cd1f29c324c5d99c16
+DIST duplicity-0.7.07.1.tar.gz 1539310 SHA256 594c6d0e723e56f8a7114d57811c613622d535cafdef4a3643a4d4c89c1904f8 SHA512 363266232763791bac9e84a9e345dda6ffa278a89597a094540088e12e47b56cb2459f72073c0020b77504514149b1ccb9bed7a67e516443a674975954f49129 WHIRLPOOL 041ea4dcc127e7cf5cca04c2037776fdf224cabe741f18a4de4e6e18fe1c4260eeed20892f91c43b7dbb0a04d246b67e8f52ab364b5bbc43a765e50ea05be092
diff --git a/app-backup/duplicity/duplicity-0.7.07.1.ebuild b/app-backup/duplicity/duplicity-0.7.07.1.ebuild
new file mode 100644
index 000000000000..3b9b288448be
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.7.07.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(get_version_component_range 1-2)-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/lockfile
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # workaround until failing test is fixed
+ local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
+
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die "Couldn't remove unnecessary COPYING file."
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ einfo "Duplicity has many optional dependencies to support various backends."
+ einfo "Currently it's up to you to install them as necessary."
+}