summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-19 02:25:14 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-19 02:26:11 -0400
commit636c0d4b61718a2b53dd75105c6fc36f812ac2cb (patch)
tree99c35a8b939d56d249299969b482c91c8aeb492e /app-backup/duplicity
parentdev-python/paramiko: version bump to 2.4.1 (diff)
downloadgentoo-636c0d4b61718a2b53dd75105c6fc36f812ac2cb.tar.gz
gentoo-636c0d4b61718a2b53dd75105c6fc36f812ac2cb.tar.bz2
gentoo-636c0d4b61718a2b53dd75105c6fc36f812ac2cb.zip
app-backup/duplicity: version bump to 0.7.17
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-0.7.17.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 20a59a91ee64..edb4b512a4d5 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -5,3 +5,4 @@ DIST duplicity-0.7.13.1.tar.gz 1553736 BLAKE2B 607a469abc7f152f564628fda444d0c30
DIST duplicity-0.7.14.tar.gz 1556110 BLAKE2B 32d4d7f941a09e85915724352ec14d6ed1bdb6a36f55e2160fe4a272868ab6c92f4917f4672183f38dbb3f38a1fa188eedd62ed9063b89b6c31d240ca268fabf SHA512 d814a4da2b23fb586bf2a7a29532ba082756470786f883d9b8cfcd856eabf0db0cdd8e9af5557fe861e439ab058e7586652f91c82c9b99c123cd14c7598b8fc2
DIST duplicity-0.7.15.tar.gz 1563272 BLAKE2B 1a5487d863253298ecab0bf328bc7e4aa7ac7df4e2b2dd47fd60b674310bcb9046e96546860fb6f299cddeb3ad384abae615a065759798e7215addb064d4582b SHA512 7cdcf1c707e9bdbbc250afcd359978607454b1614128d2b7f09403867195795606794c5f193dc869579ae8c3a9251d7ef8f9acd66d4e69bce91344d7c046ca90
DIST duplicity-0.7.16.tar.gz 1563676 BLAKE2B 67e1a205a880b2658ed265efa46590553537881d82af21f538fe0b524338ed8450ded1dcc30089ecf13892f5cccc284fe2acd3dbb1a17597557640ccbb1376cd SHA512 552f63848ce90ccd8481136df6c0918bbf2463dde00d4e54f0af3693dc5439551ac086dc43b7b7191d1dcf0b710d7391b6c627ce0effd14a59beb0b5fa06a804
+DIST duplicity-0.7.17.tar.gz 1719145 BLAKE2B fb5b3b3319305e63aaabcf4feef89d8a9c7b84d8e1ff09082cbfb49ebb7129a88afe6c85f6db892c0fdc8a27ca2b247e903e20a2f7b7fd9d6ced0aa77f15a2d4 SHA512 a7fa3f26709bcb25be519a20d65a196072a49ca468ace84b4876a815efea23fc1ed5b77abf765475fb8a08e3138349bf1d48e0ce22816ef66526463b646e12a3
diff --git a/app-backup/duplicity/duplicity-0.7.17.ebuild b/app-backup/duplicity/duplicity-0.7.17.ebuild
new file mode 100644
index 000000000000..b2f160dd6d9e
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.7.17.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(get_version_component_range 1-2)-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # workaround until failing test is fixed
+ local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
+
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ einfo "Duplicity has many optional dependencies to support various backends."
+ einfo "Currently it's up to you to install them as necessary."
+}