summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2020-05-07 12:30:52 -0400
committerRichard Freeman <rich0@gentoo.org>2020-05-07 12:52:46 -0400
commitd554635fb1e0683395b6cf1c8ac205e8c9bc0327 (patch)
tree357fbb370038dd0dae1ac18273193964ebced70e /app-backup/duplicity
parentnet-misc/teamviewer: fix manifest (diff)
downloadgentoo-d554635fb1e0683395b6cf1c8ac205e8c9bc0327.tar.gz
gentoo-d554635fb1e0683395b6cf1c8ac205e8c9bc0327.tar.bz2
gentoo-d554635fb1e0683395b6cf1c8ac205e8c9bc0327.zip
app-backup/duplicity: setup.py fix to allow python-exec wrapping
Thanks to Alexander who discovered the root cause of this problem. Credit: Alexander Tsoy Closes: https://bugs.gentoo.org/710500 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/duplicity-0.8.12.1612-r1.ebuild50
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.12.1612-fix-docs-cmd.patch29
2 files changed, 79 insertions, 0 deletions
diff --git a/app-backup/duplicity/duplicity-0.8.12.1612-r1.ebuild b/app-backup/duplicity/duplicity-0.8.12.1612-r1.ebuild
new file mode 100644
index 000000000000..7c75e96f148a
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.8.12.1612-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/$(ver_cut 1-3)/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs-cmd.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-0.8.12.1612-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-0.8.12.1612-fix-docs-cmd.patch
new file mode 100644
index 000000000000..89cd583e6bff
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-0.8.12.1612-fix-docs-cmd.patch
@@ -0,0 +1,29 @@
+--- duplicity-0.8.12.1612/setup.py 2020-05-07 12:07:21.571865871 -0400
++++ duplicity-0.8.12.1612/setup.py 2020-05-07 12:08:29.617846122 -0400
+@@ -88,18 +88,6 @@
+ u'bin/rdiffdir.1'
+ ]
+ ),
+- (u'share/doc/duplicity-%s' % version_string,
+- [
+- u'AUTHORS',
+- u'CHANGELOG',
+- u'Changelog.GNU',
+- u'COPYING',
+- u'README',
+- u'README-LOG',
+- u'README-REPO',
+- u'README-TESTING',
+- ],
+- ),
+ ]
+
+ if not os.environ.get(u'READTHEDOCS') == u'True':
+@@ -265,7 +253,6 @@
+ ],
+ test_suite=u"testing",
+ cmdclass={
+- u"build_scripts": BSCommand,
+ u"install": InstallCommand,
+ u"test": TestCommand,
+ },