summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-01 06:25:32 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-01 06:27:31 -0400
commite8ed1e9000068d0c0e9f57134962563bd2a25993 (patch)
tree94bb97881739d6970290ff7fa77b4235ff3ff5b9 /app-backup/duplicity
parentdev-python/pexpect: remove sourceforge from upstream metadata (diff)
downloadgentoo-e8ed1e9000068d0c0e9f57134962563bd2a25993.tar.gz
gentoo-e8ed1e9000068d0c0e9f57134962563bd2a25993.tar.bz2
gentoo-e8ed1e9000068d0c0e9f57134962563bd2a25993.zip
app-backup/duplicity: version bump to 0.7.14
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-0.7.14.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 3b1eaa534a4e..0085c5e68806 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -2,3 +2,4 @@ DIST duplicity-0.7.10.tar.gz 1543523 SHA256 485fef15526d163c061e00ec08de216cf7d6
DIST duplicity-0.7.11.tar.gz 1550197 SHA256 b047a1590a1f5bb3974643ad2cc9dfdd32f61adbf2c1989191fb12cb59c2ec07 SHA512 81ccb868625b261356b9cb2439659eb7574343c0a15ea7db099746216689a881d9a37b05711c232103ae0e7660b5cdc7dff6475eda81ecbdcfc28bced0eabe75 WHIRLPOOL 1c106933fe4e9ba535a7923e93474457f2ede8979c2f9ed400fb7a819872c05ec2adfd08920d7b81b3e97feb90844f141721fc5ff184e97ec0b3df9da1d311df
DIST duplicity-0.7.12.tar.gz 1552442 SHA256 11cbad44a90891af1bf9e294260ba7c21a1660ccd3ab2c6e736ba74ac5cf0fe6 SHA512 8a532e7bb548c170184666a0ba2b41a15f3002c14edd64b1b1eb4df862647fc6dfde797d6ecf38e326d7c160c31ff521baf351e520835495e1d0e2ddbdb19f0f WHIRLPOOL 872d0b52a0f73507849d585fd5888d4754d5711ab5cc48d72b571cfb14fd1278093022f52238facf608c8b26aa0149f2e614a4819c85aeb9ee94305e81824147
DIST duplicity-0.7.13.1.tar.gz 1553736 SHA256 adb8668fb10e0b0f91cb77f758d02c02bf5c02e6c4835904a82cbdab6db4bef2 SHA512 08672910e61a089086992a1106ffc1e161ae3173514d35ae854eac719a095e48efaf7e298c1329ba3b439c0e97236644e88c615a013bd0e8ea9d956b38346ca6 WHIRLPOOL 2a9fddd1c41cadaa713c83805bce5d3e2de01540de29a47c7d545236e9e713b2004abfbae9977a115727db5fc661904f679cae7d0c9fb01ece04bdce212fb08c
+DIST duplicity-0.7.14.tar.gz 1556110 SHA256 7a3eb74a2a36b004b10add2970b37cfbac0bd693d79513e6311c8e4b8c3dd73e SHA512 d814a4da2b23fb586bf2a7a29532ba082756470786f883d9b8cfcd856eabf0db0cdd8e9af5557fe861e439ab058e7586652f91c82c9b99c123cd14c7598b8fc2 WHIRLPOOL 94cf54460e5187a3b2d009eb8cff95c98400e112cc3703bab966ceea33e7414b28ed90d22e3fc46bc7e5fa78a37689c31e49907efb93ad9ca8bbd0bf00645668
diff --git a/app-backup/duplicity/duplicity-0.7.14.ebuild b/app-backup/duplicity/duplicity-0.7.14.ebuild
new file mode 100644
index 000000000000..46196df24caa
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.7.14.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(get_version_component_range 1-2)-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # workaround until failing test is fixed
+ local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
+
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ einfo "Duplicity has many optional dependencies to support various backends."
+ einfo "Currently it's up to you to install them as necessary."
+}