summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-12-22 22:16:59 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-12-22 22:17:17 +1100
commita86cabb000c60ec8496c73d5e28ea56686b98a40 (patch)
treec3781b6481a89d27f259024fb98dfb5452a56df9 /app-backup/luckybackup
parentapp-office/texmacs: bump to 1.99.6 (diff)
downloadgentoo-a86cabb000c60ec8496c73d5e28ea56686b98a40.tar.gz
gentoo-a86cabb000c60ec8496c73d5e28ea56686b98a40.tar.bz2
gentoo-a86cabb000c60ec8496c73d5e28ea56686b98a40.zip
app-backup/luckybackup: version bump 0.4.9
Closes: https://bugs.gentoo.org/637106 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'app-backup/luckybackup')
-rw-r--r--app-backup/luckybackup/Manifest1
-rw-r--r--app-backup/luckybackup/luckybackup-0.4.9.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-backup/luckybackup/Manifest b/app-backup/luckybackup/Manifest
index 872bcc196ca1..40389fe3dce7 100644
--- a/app-backup/luckybackup/Manifest
+++ b/app-backup/luckybackup/Manifest
@@ -1 +1,2 @@
DIST luckybackup-0.4.8.tar.gz 5710203 BLAKE2B a0efe350aecaae759cb8c7d2f51eeaa71caa7b267064ccb0a49f44465df53b6b2a41ebbd6794a5bdd2b44b8d1a402648da0ff243880237c6e3d64d505b5d5bd9 SHA512 48e73f8b5897a09f64f3755dc094ef50031c607ecfca25c238b45ca5bef7f2645081b7c665a9b7c3c3da2f214f91b229a559d723df8ddb6446aa23e68b266076
+DIST luckybackup-0.4.9.tar.gz 5954338 BLAKE2B 632738f8c422ba7d56536fae866ce31d224910b41495e4df3be28a8013ba776e30b4d8e70ceb26c92d28aaf70c96402f27687c55d8f5d7aa5d405bab506a66be SHA512 86d6f1bd84f3bfd89734f0f2066cb17bbf9b4ede96167398de03a460c14d24bf4b50a91bb380655ace9a23497271e102b940ea99a7595cf17f596660dae7f7dd
diff --git a/app-backup/luckybackup/luckybackup-0.4.9.ebuild b/app-backup/luckybackup/luckybackup-0.4.9.ebuild
new file mode 100644
index 000000000000..4ae8962c48c1
--- /dev/null
+++ b/app-backup/luckybackup/luckybackup-0.4.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Powerful and flexible backup (and syncing) tool, using RSync and Qt"
+HOMEPAGE="http://luckybackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+
+DOCS=( readme/{AUTHORS,README,TODO,TRANSLATIONS,changelog} )
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:g" \
+ -e "s:/usr/share/doc/packages/${PN}:/usr/share/doc/${PF}:g" \
+ luckybackup.pro src/global.cpp || die "sed failed"
+
+ # The su-to-root command is an ubuntu-specific script so it will
+ # not work with Gentoo. No reason to have it anyway.
+ sed -i -e "/^Exec/s:=.*:=/usr/bin/${PN}:" menu/${PN}-gnome-su.desktop \
+ || die "failed to remove su-to-root"
+
+ # causes empty directory to be installed
+ sed -i -e '/^INSTALLS/s/debianmenu //' luckybackup.pro \
+ || die "sed installs failed"
+
+ # remove text version - cannot remote HTML version
+ # as it's used within the application
+ rm license/gpl.txt || die "rm failed"
+
+ default
+}
+
+src_configure() {
+ eqmake5 ${PN}.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}