summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/obnam/obnam-1.13.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/obnam/obnam-1.13.ebuild')
-rw-r--r--app-backup/obnam/obnam-1.13.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-backup/obnam/obnam-1.13.ebuild b/app-backup/obnam/obnam-1.13.ebuild
new file mode 100644
index 000000000000..cd42b25e8071
--- /dev/null
+++ b/app-backup/obnam/obnam-1.13.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A backup program that supports encryption and deduplication"
+HOMEPAGE="http://obnam.org/"
+SRC_URI="http://git.liw.fi/cgi-bin/cgit/cgit.cgi/obnam/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/cliapp
+ dev-python/fuse-python
+ dev-python/larch
+ !=dev-python/paramiko-1.13.0
+ || ( <dev-python/paramiko-1.13.0 >dev-python/paramiko-1.13.0 )
+ dev-python/pyyaml
+ dev-python/tracing
+ dev-python/ttystatus
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=( )
+
+src_compile() {
+ addwrite /proc/self/comm
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+ find "${D}" -name "obnam-viewprof*" -delete
+ insinto /etc
+ doins "${FILESDIR}"/obnam.conf
+ keepdir /var/log/obnam
+}
+
+pkg_postinst() {
+ if [[ $REPLACING_VERSIONS < "1.2" ]]; then
+ elog "You will need to setup a config file before running obnam for the first time."
+ elog "For details, please see the obnam(1) manual page."
+ elog "An example file has been installed as /etc/obnam.conf for your convenience."
+ fi
+}