summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Hendrikx (whyscream) <tom@whyscream.net>2017-02-05 15:54:59 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-02-05 16:02:00 -0800
commit7ed538f4aa1258d904ac7dce66c26ab013a1a155 (patch)
tree54c8c1114d1a688d88ce0f4c2dc892cae031dd5c /app-backup/rdup
parentmedia-sound/bluez-alsa: Added conf.d file (bug #608354). (diff)
downloadgentoo-7ed538f4aa1258d904ac7dce66c26ab013a1a155.tar.gz
gentoo-7ed538f4aa1258d904ac7dce66c26ab013a1a155.tar.bz2
gentoo-7ed538f4aa1258d904ac7dce66c26ab013a1a155.zip
app-backup/rdup: new package.
(Imported from rdup-1.1.14 import from Sunrise, EAPI & version bumped). Package-Manager: portage-2.3.2 Fixes: https://bugs.gentoo.org/show_bug.cgi?id=196309 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-backup/rdup')
-rw-r--r--app-backup/rdup/Manifest1
-rw-r--r--app-backup/rdup/metadata.xml11
-rw-r--r--app-backup/rdup/rdup-1.1.15.ebuild42
3 files changed, 54 insertions, 0 deletions
diff --git a/app-backup/rdup/Manifest b/app-backup/rdup/Manifest
new file mode 100644
index 000000000000..a18b31f94ed6
--- /dev/null
+++ b/app-backup/rdup/Manifest
@@ -0,0 +1 @@
+DIST rdup-1.1.15.tar.gz 333646 SHA256 787b8c37e88be810a710210a9d9f6966b544b1389a738aadba3903c71e0c29cb SHA512 e377ec29e0dacae306ee58c935c9738f32d177e1c2575e4fa3618d2753d248f2898633dde46da81410271205458ccf0d3d885e3eebc5f1948afc5cd9e99ce7c3 WHIRLPOOL a82eac7a80ab02436343687f62bbab643027854771e2031d577abc71495aa7e63c0185580466527704906035e023372809088b8a08686ce438211ddffb7b5521
diff --git a/app-backup/rdup/metadata.xml b/app-backup/rdup/metadata.xml
new file mode 100644
index 000000000000..9f9793a7335b
--- /dev/null
+++ b/app-backup/rdup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">miekg/rdup</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-backup/rdup/rdup-1.1.15.ebuild b/app-backup/rdup/rdup-1.1.15.ebuild
new file mode 100644
index 000000000000..952ae221709b
--- /dev/null
+++ b/app-backup/rdup/rdup-1.1.15.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="Generate a file list suitable for full or incremental backups"
+HOMEPAGE="https://github.com/miekg/rdup/releases"
+SRC_URI="https://github.com/miekg/rdup/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-libs/glib:2
+ dev-libs/libpcre
+ dev-libs/nettle"
+DEPEND="${RDEPEND}
+ test? ( dev-util/dejagnu )"
+
+src_prepare() {
+ default_src_prepare
+ sed -i -e 's/ -Werror//' GNUmakefile.in || die "Failed to fix Makefile"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_test() {
+ if use debug; then
+ ewarn "Test phase skipped, as it is known to fail with USE=\"debug\"."
+ else
+ default_src_test
+ fi
+}