summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/reoback/reoback-1.0_p3-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/reoback/reoback-1.0_p3-r1.ebuild')
-rw-r--r--app-backup/reoback/reoback-1.0_p3-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-backup/reoback/reoback-1.0_p3-r1.ebuild b/app-backup/reoback/reoback-1.0_p3-r1.ebuild
new file mode 100644
index 000000000000..6c778bc10902
--- /dev/null
+++ b/app-backup/reoback/reoback-1.0_p3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Reoback Backup Solution"
+HOMEPAGE="http://reoback.sourceforge.net/"
+SRC_URI="mirror://sourceforge/reoback/reoback-${PV/_p/_r}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.6.1"
+DEPEND=">=app-arch/tar-1.13"
+
+S=${WORKDIR}/${PN}-${PV/_*}
+
+src_prepare() {
+ ecvs_clean
+ sed \
+ -e '/^config=/s:=.*:=/etc/reoback/settings.conf:' \
+ -e '/^reoback=/s:=.*:=/usr/sbin/reoback.pl:' \
+ -i run_reoback.sh || die
+}
+
+src_install() {
+ dosbin reoback.pl
+ insinto /etc/reoback
+ doins conf/*
+ fperms o-x /usr/sbin/reoback.pl
+ insinto /etc/cron.daily
+ newins run_reoback.sh reoback
+ dodoc docs/{BUGS,CHANGES,INSTALL,MANUALS,README,TODO}
+}
+
+pkg_postinst() {
+ elog "Reoback can now be activated by simply configuring the files in"
+ elog "/etc/reoback and then doing: chmod +x /etc/cron.daily/reoback"
+}