summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2022-03-19 15:24:07 -0400
committerRichard Freeman <rich0@gentoo.org>2022-03-19 15:30:40 -0400
commit20d139377cd113f60017cce97e3e10c13e9175c4 (patch)
tree7d9a780d14db2daab9d215b5921b40572b6da0ea /app-backup
parentapp-editors/zile: x86 stable wrt bug #835557 (diff)
downloadgentoo-20d139377cd113f60017cce97e3e10c13e9175c4.tar.gz
gentoo-20d139377cd113f60017cce97e3e10c13e9175c4.tar.bz2
gentoo-20d139377cd113f60017cce97e3e10c13e9175c4.zip
app-backup/duplicity: add 0.8.22
Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-0.8.22.ebuild51
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.22-fix-docs-cmd.patch20
3 files changed, 72 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 8ef491a1d07f..d9694e370b95 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -1,3 +1,4 @@
DIST duplicity-0.8.19.tar.gz 1372739 BLAKE2B 6a5a642597529eea37c7224cbfdd115db42c16f6391e553454f8f82cea86240bbd68a62513129496a1f978411fdeec50c3d918bb99b470fa1444fd77e7e6c9b7 SHA512 c1a1f5894f8b94ac61bd98270f138c58ef5a68f3624e7e88224b15539ca6e08874df9cebb36b10167d133b1af6a93b29e7bf4084c348b9cd7914ff24415be57c
DIST duplicity-0.8.20.tar.gz 1376671 BLAKE2B af3fd95b699cd9b3c6bbe259e0dd898fc058461efcb2d1d51c8c2d539df7e32fe70fb6af4b314cd6fce219345f23eb0ab342d0c7f28b05ec1ee4333c02d93415 SHA512 ac43473a18031fa33cee0b7a3dc6b33c830ba9d19a0129c065a226824af8aacf00230ae05bf2e0d7614ad4ce9724e40e9b8305114175af63d8a8a8642ffdce67
DIST duplicity-0.8.21.tar.gz 1375469 BLAKE2B 15da671b30305415dfafdef50f5f57eaea0d6504a3f35845bf4570bb0cd2d6d3c879e94dda5739f30acd54748ef7abb993405660d24cf96ab919cec08690e015 SHA512 573c79937e4b19e99d167fddaebfd7b747d3c5f240b14e575fecd45a225c6c279d5ce0132645bbefcddcbc688f9d67317a3ec3a0816fcb4ff303b217fe10b012
+DIST duplicity-0.8.22.tar.gz 1408482 BLAKE2B 3a8b6eb79d5f67e8f274bdaaaf0bb5b6c9f0ebf91a3b6a849b876cdf2c9af0f5435946150b5db6ab5e524cedc5b98b40c456b1de0fe8c6e33c024fe3c7d881fa SHA512 474237e3ca9876fb124baf9871f781b8347c85e76b7b4191d6993a76fb4728500091c74ed0943c6c22d69651c08094b6d155eca742d1711bebe676734c84d12a
diff --git a/app-backup/duplicity/duplicity-0.8.22.ebuild b/app-backup/duplicity/duplicity-0.8.22.ebuild
new file mode 100644
index 000000000000..cb3a9813e1dd
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.8.22.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_8 python3_9 python3_10 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="https://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/$(ver_cut 1-3)/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs-cmd.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-0.8.22-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-0.8.22-fix-docs-cmd.patch
new file mode 100644
index 000000000000..450c9f1d85d4
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-0.8.22-fix-docs-cmd.patch
@@ -0,0 +1,20 @@
+--- duplicity-0.8.22/setup.py 2022-03-19 15:08:36.755624771 -0400
++++ duplicity-0.8.22/setup.py 2022-03-19 15:09:38.332763172 -0400
+@@ -94,17 +94,6 @@
+ u'bin/rdiffdir.1'
+ ]
+ ),
+- (u'share/doc/duplicity-%s' % Version,
+- [
+- u'CHANGELOG.md',
+- u'CONTRIBUTING.md',
+- u'COPYING',
+- u'README.md',
+- u'README-LOG.md',
+- u'README-REPO.md',
+- u'README-TESTING.md',
+- ],
+- ),
+ ]
+
+ if not os.environ.get(u'READTHEDOCS') == u'True':