summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2022-06-23 21:23:20 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-07-05 10:40:29 +0300
commit44f5d74f86524ee9a4b60bfe022cba5eaa11dd0c (patch)
treeb8e008e52a2df62db2e11c39e10fba7a2a91ab70 /app-backup
parentmedia-gfx/flameshot: bump to v12.0.0 (diff)
downloadgentoo-44f5d74f86524ee9a4b60bfe022cba5eaa11dd0c.tar.gz
gentoo-44f5d74f86524ee9a4b60bfe022cba5eaa11dd0c.tar.bz2
gentoo-44f5d74f86524ee9a4b60bfe022cba5eaa11dd0c.zip
app-backup/dar: add 2.7.6
Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/26059 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/dar/Manifest1
-rw-r--r--app-backup/dar/dar-2.7.6.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index 48e604c1f49b..12954d8b4057 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1 +1,2 @@
DIST dar-2.7.5.tar.gz 2404076 BLAKE2B 2887629cecf069cfb5063132299279b8be985785485c6f04a8389dfd4930f00b073b421fbb17915d69f5efd46ebb4c3d371c10d3936bfb16d82a191218af350d SHA512 a4e01dce8a078ba81b3032a1910d75f0f59a23511246f570a50ade135f49f11e522ed8916a947aece1799dcd1d37308ba6e4a009313b80d6a1561698c3d5623a
+DIST dar-2.7.6.tar.gz 2410200 BLAKE2B 925b4854c66fec9287e0f42d213f94f208b5248d09eb6abe4e36a41df1fc57641d7a6b41e1f8aaa202e6f74ad04399c70a8cb74dc63685985a5671ba54efdf93 SHA512 517fa06a5b8caa53ad111e4287446583f328ee2027169db067610877e05291e63179c1bdd92312a6885d1c7eba0566a86301e974d1d48df56f0fce9ccfdb3a19
diff --git a/app-backup/dar/dar-2.7.6.ebuild b/app-backup/dar/dar-2.7.6.ebuild
new file mode 100644
index 000000000000..ef7cc64225b7
--- /dev/null
+++ b/app-backup/dar/dar-2.7.6.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lz4 lzo nls rsync threads xattr"
+
+REQUIRED_USE="?? ( dar32 dar64 )
+ gpg? ( gcrypt )"
+
+RESTRICT="test" # need to be run as root
+
+RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ sys-libs/libcap
+ >=sys-libs/zlib-1.2.3:=
+ argon2? ( app-crypt/argon2:= )
+ curl? ( net-misc/curl )
+ gcrypt? (
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ )
+ gpg? ( app-crypt/gpgme:= )
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:2 )
+ nls? ( virtual/libintl )
+ rsync? ( net-libs/librsync:= )
+ threads? ( dev-libs/libthreadar )
+ xattr? ( sys-apps/attr )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+ local myconf=(
+ --disable-dar-static
+ --disable-python-binding
+ --disable-upx
+ $(usev !argon2 --disable-libargon2-linking)
+ $(usev !curl --disable-libcurl-linking)
+ $(usev dar32 --enable-mode=32)
+ $(usev dar64 --enable-mode=64)
+ $(usev !doc --disable-build-html)
+ $(usev !gcrypt --disable-libgcrypt-linking)
+ $(usev !gpg --disable-gpgme-linking)
+ $(usev !lz4 --disable-liblz4-linking)
+ $(usev !lzo --disable-liblzo2-linking)
+ $(usev !nls --disable-nls)
+ $(usev !rsync --disable-librsync-linking)
+ $(usev !threads --disable-threadar)
+ $(usev !xattr --disable-ea-support)
+ )
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+
+ # Bug 729150
+ rm "${ED}/usr/share/doc/${PF}/html/samples/MyBackup.sh.tar.gz" || die
+}