summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-06-05 19:10:12 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-06-05 19:10:12 -0400
commit60f8b7821464695a2c060eacd062966671459094 (patch)
tree9cb3cd29a875293135c96bc5ac811956f88b1762 /app-backup
parentwww-servers/varnish: remove older unstable versions (diff)
downloadgentoo-60f8b7821464695a2c060eacd062966671459094.tar.gz
gentoo-60f8b7821464695a2c060eacd062966671459094.tar.bz2
gentoo-60f8b7821464695a2c060eacd062966671459094.zip
app-backup/spideroak-bin: bump to version 6.3.0, bug #616052
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/spideroak-bin/Manifest2
-rw-r--r--app-backup/spideroak-bin/spideroak-bin-6.3.0.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/app-backup/spideroak-bin/Manifest b/app-backup/spideroak-bin/Manifest
index e253b7b6c91f..b86ea3ff4deb 100644
--- a/app-backup/spideroak-bin/Manifest
+++ b/app-backup/spideroak-bin/Manifest
@@ -2,3 +2,5 @@ DIST spideroak-bin-6.1.3_amd64.deb 26655852 SHA256 65ecab3096e6de675fd9facf81f38
DIST spideroak-bin-6.1.3_x86.deb 26173318 SHA256 50fd7d442291bb9ec64d51308444c83b7d76d55bafcc3e9f5d3009e6a49eee0f SHA512 0ddf1be909b44042e3fe0f7e791558e50c649a3d4472c3a05c78835c593d6db3369c0e862b79f2a4812232503346defc1c889fbc4c701a125d3364810b524481 WHIRLPOOL 2e19e4ac0f9028acea19eb2f395faba2031959c09544c07a7f10c690f67317558ac0fbdf2e1fe1b52a922e4ac9480486348b0c4cf053b03336018d3aef7f2dab
DIST spideroak-bin-6.1.5_amd64.deb 26882606 SHA256 7ef458381c17f7a3712043aa672b5509500e7e6999cd52ba5d85ba76f7a29d2c SHA512 c23e41d359879ce671f8af66e32d08affe10c92492ed46dc6eea5942f14190d28a4b1b96722959bfcec98b05f9176c0a959c93c32bf22709139332b42d805a52 WHIRLPOOL 8f9b56f091951dafb6849cfbafd60314708dd5a5deed0852d5bb06869b36f1fa5d8e55508407c5bbf34024523531bfe26325fce7895ac04b59f6f1dd1aa50c58
DIST spideroak-bin-6.1.5_x86.deb 26405076 SHA256 a001e464b87406e775f421ff041fbc80a3f3b33548c792a095c9632e137a3e89 SHA512 4aa87c2fd35569bb4acaf5492ca520d66bb9d53c5a53d5e8f418ae0518cb143f35bc769a7d37bc1ea6e4536b944780a3403d3800c45973bed537f573f3e07d0a WHIRLPOOL 7471b8ebf394cbcbc05400cc0e0c390ea30d92194567458b6955bd9a25f5f40fbe27c52e30767e467aa4f45ecf6fa304b82ab60bf30d1408846c4cff7f4087b9
+DIST spideroak-bin-6.3.0_amd64.deb 26860946 SHA256 82f39594ac3c5b22324912a633b51a03dd1d6a6b3460bf9426f3bfe712af12e7 SHA512 b9c2635c141c4aaffa0a744b155563a64f4ec16c7f07e38c15cc47db5d810a13997facb4cf75f1567212e613abfa2da6477dcb7ee8f81b35276f115ff3d71051 WHIRLPOOL c9b532c9f90508447baf7d080ccda9e358a386352fd917d2e473183c4afc3aa89b211a789ce0442ced0d5d86ebe8b5bf3b9e2d4ce6eb4087773dd1bc81abfe7a
+DIST spideroak-bin-6.3.0_x86.deb 26384374 SHA256 943b324f1f1daae8fc52e952665a0b8f543f5294e21736a90c94f234a217512b SHA512 beb19703541df684f9c322916cb033846b730f5da7efa34a90250ce6da46f34f741fcfe12bc41bc82770b6cfd54f5376314c3689885d1ce1591f162361339a99 WHIRLPOOL f290963d2f714bf5c63fd03cf4d53ae455ef7520289149f4fcaf88693cd8dd403cb4686e6c00728da2a883096047a6d6fc0d1d43abff4dad5e68a6145f7a2665
diff --git a/app-backup/spideroak-bin/spideroak-bin-6.3.0.ebuild b/app-backup/spideroak-bin/spideroak-bin-6.3.0.ebuild
new file mode 100644
index 000000000000..98ee8c0cc491
--- /dev/null
+++ b/app-backup/spideroak-bin/spideroak-bin-6.3.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils unpacker
+
+DESCRIPTION="Secure free online backup, storage, and sharing system"
+HOMEPAGE="https://spideroak.com"
+
+SRC_URI_BASE="https://spideroak.com/release/spideroak"
+SRC_URI="x86? ( ${SRC_URI_BASE}/deb_x86 -> ${P}_x86.deb )
+ amd64? ( ${SRC_URI_BASE}/deb_x64 -> ${P}_amd64.deb )"
+
+RESTRICT="mirror strip"
+
+LICENSE="spideroak"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus X"
+
+DEPEND="dev-util/patchelf"
+RDEPEND="
+ app-crypt/mit-krb5[keyutils]
+ dbus? ( sys-apps/dbus )
+ X? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ )
+"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ # Set RPATH for preserve-libs handling (bug #400979).
+ cd "${S}/opt/SpiderOakONE/lib" || die
+ local x
+ for x in `find` ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+
+ #Remove the libraries that break compatibility in modern systems
+ #SpiderOak will use the system libs instead
+ rm -f "${S}/opt/SpiderOakONE/lib/libstdc++.so.6"
+ rm -f "${S}/opt/SpiderOakONE/lib/libgcc_s.so.1"
+ rm -f "${S}/opt/SpiderOakONE/lib/libpng12.so.0"
+ rm -f "${S}/opt/SpiderOakONE/lib/libz.so.1"
+}
+
+src_install() {
+ #install the wrapper script
+ exeinto /usr/bin
+ doexe usr/bin/SpiderOakONE
+
+ # inotify_dir_watcher needs to be marked executable, bug #453266
+ #chmod a+rx opt/SpiderOakONE/lib/inotify_dir_watcher
+
+ #install the executable
+ exeinto /opt/SpiderOakONE/lib
+ doexe opt/SpiderOakONE/lib/SpiderOakONE
+ doexe opt/SpiderOakONE/lib/inotify_dir_watcher
+ rm -f opt/SpiderOakONE/lib/{SpiderOakONE,inotify_dir_watcher}
+
+ #install the prebundled libraries
+ insinto /opt/SpiderOakONE
+ doins -r opt/SpiderOakONE/lib
+
+ #install the config files
+ use dbus || rm -rf etc/dbus-1
+ insinto /
+ doins -r etc
+
+ #install the manpage
+ doman usr/share/man/man1/SpiderOakONE.1.gz
+
+ if use X; then
+ domenu usr/share/applications/SpiderOakONE.desktop
+ doicon usr/share/pixmaps/SpiderOakONE.png
+ fi
+}
+
+pkg_postinst() {
+ if ! use X; then
+ einfo "For instructions on running SpiderOakONE without a GUI, please read the FAQ:"
+ einfo " https://spideroak.com/faq/questions/62/how_do_i_install_spideroak_on_a_headless_linux_server/"
+ einfo " https://spideroak.com/faq/questions/67/how_can_i_use_spideroak_from_the_commandline/"
+ fi
+}