summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-12-24 18:59:32 +0100
committerMarek Szuba <marecki@gentoo.org>2023-12-24 22:06:55 +0100
commit891099a8a8b935c5e1ccfd98c63c05dbd7f1a18b (patch)
tree0b0c33ca622e2cae09eb294c7972af3a16181b2c /app-backup
parentdev-python/apprise: new package, add 1.6.0 (diff)
downloadgentoo-891099a8a8b935c5e1ccfd98c63c05dbd7f1a18b.tar.gz
gentoo-891099a8a8b935c5e1ccfd98c63c05dbd7f1a18b.tar.bz2
gentoo-891099a8a8b935c5e1ccfd98c63c05dbd7f1a18b.zip
app-backup/borgmatic: add 1.8.5
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.8.5.ebuild80
-rw-r--r--app-backup/borgmatic/metadata.xml4
3 files changed, 85 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index f9b2b79af9f1..94d48b500c88 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,2 +1,3 @@
DIST borgmatic-1.8.2.tar.gz 396972 BLAKE2B d9444ec49c3d325d865d553fa1cb28de9416aa36e999ef6452c62a9a6519e58afbc922398c52f3a1de441fd8da02e5618bc03a67baae161677a15a1780209788 SHA512 8de49c071c54516d0fb3f0d918f05226ac00519cc0605eacf204795a239554764fd1f3b0f44f3110fc551d6a89e92a59ca34ddebbfb02bf3deabc326f81ccf9c
DIST borgmatic-1.8.3.tar.gz 399031 BLAKE2B d560ccf69f86f35951521e44fba03a4704161abfe1208a8ef23067ba09b0060be84605761a2fa0b0878d466df10391a9314e85480c15af22faaf326c84211dd9 SHA512 3f798fddadb12742928e1542d1c71838b58870ecea18c62b260829880ae7ba0ec26303548a60ff7c8071b49eb630320bb055a9a1d67e4952c8952140f09100d2
+DIST borgmatic-1.8.5.tar.gz 580628 BLAKE2B ca4ae3fcda05ed4a7b11e98f767853920d1ed3053dedaedeaf16124c43ae32a4d89bc2a1ed594d88cb1e8da9da79ad75459dd3a8034b70c1a2d8b57776b1a725 SHA512 96681ee9d4aa55edeee1ab2ab2929022a3c49c60a20313c129d53736b40b0c46a3a6a5537ba3355d7cef74988655ed5af4ab689df9130de1373bcf6a8a665a9e
diff --git a/app-backup/borgmatic/borgmatic-1.8.5.ebuild b/app-backup/borgmatic/borgmatic-1.8.5.ebuild
new file mode 100644
index 000000000000..9cc0fde11fb4
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.8.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="apprise"
+
+REQUIRED_USE="test? ( apprise )"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')
+ apprise? ( $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ ') )"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.13-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " ${PN} config generate"
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.8.0; then
+ ewarn "Please be warned that ${PN}-1.8.0 has introduced several breaking changes."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://github.com/borgmatic-collective/borgmatic/releases/tag/1.8.0"
+ ewarn
+ break
+ fi
+ done
+ fi
+ elog
+ elog "Systemd users wishing to periodically run ${PN} can use the provided timer and service units."
+}
diff --git a/app-backup/borgmatic/metadata.xml b/app-backup/borgmatic/metadata.xml
index 8891ce86c8d5..4365e7fa2b90 100644
--- a/app-backup/borgmatic/metadata.xml
+++ b/app-backup/borgmatic/metadata.xml
@@ -9,4 +9,8 @@
<remote-id type="github">borgmatic-collective/borgmatic</remote-id>
<remote-id type="pypi">borgmatic</remote-id>
</upstream>
+<use>
+ <flag name="apprise">Allow backup monitoring to send notification to a wide variety
+ of services, using <pkg>dev-python/apprise</pkg></flag>
+</use>
</pkgmetadata>