summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-07-13 14:54:44 +0200
committerMarek Szuba <marecki@gentoo.org>2020-07-13 15:16:43 +0200
commit8facf709179b59c7e7b907bf7b3c28267782d02d (patch)
tree742c711b66603b7527bb9d518126c3b82954d979 /app-backup
parentgnome-base/gdm: bump to 3.36.2 (diff)
downloadgentoo-8facf709179b59c7e7b907bf7b3c28267782d02d.tar.gz
gentoo-8facf709179b59c7e7b907bf7b3c28267782d02d.tar.bz2
gentoo-8facf709179b59c7e7b907bf7b3c28267782d02d.zip
app-backup/borgmatic: bump to 1.5.8
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.5.8.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 2fb4a5232664..44285edadb2d 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,3 +1,4 @@
DIST borgmatic-1.5.1.tar.gz 67401 BLAKE2B c11f4b9f9acc7d7bf4e482953968dbaabc33f1513ec8f20868518bca22ffcafee90569c06ec603be919d47d724dd4a3a904e44fbb40c2309d8cb78e9277b5cc7 SHA512 9ded9bd5d6db866d196fedee88737f3d3eef6cb0e61c5f55ac543602c4429adcb57608d7f6c798edfd6ac1ecd14aadd9a88fdf94ef1f0eab4c26a9d2a29c5e38
DIST borgmatic-1.5.6.tar.gz 70075 BLAKE2B 23e233c7457c25ae5b83571436dcfac4e70bf4c9a9bf9af95b8722533b48fdd82089152da220b7d61a01569233f2aedddf300c3a5ad2c69c631060f0b08e6b59 SHA512 e314fa1f20516dd52f4435c782bf634821a034925c0f11553483a1e55eef5d588e54e7abb1a88d239c1619f291548a5058a8f636d16dd829680089c20c601a79
DIST borgmatic-1.5.7.tar.gz 71084 BLAKE2B b6ab2f80af47ba49e8f584b555b910bf94dbfb72da8a55433f147410059948fa844846bea007b317f10cb76811c5da6bd1c22f7fefb5c062213670fadb326cd9 SHA512 26fa9ee1b158c05cdb3ed60faa16b4eac431691ced454149091c302876550277f622cd67e45ef42a3070896e76b94d8a39f1604a08f604bada5bab1ec6691902
+DIST borgmatic-1.5.8.tar.gz 71078 BLAKE2B 488a2d3a1689d16ac2e4e2e9e0f842fab51322a83b024f5bff742e31290d70e6acb683cfe74cc610b0bf0e3ff9d523bacd7faa309560f2ebb8b5b4820de54119 SHA512 25f38bbd48eb41ded8e315620fdcd929c10b38b89a3fc428db9e0053d4c1c46941962f6693018c5e26aa2187ed20bf366424b1b03f9c61cc56274c7008e824e9
diff --git a/app-backup/borgmatic/borgmatic-1.5.8.ebuild b/app-backup/borgmatic/borgmatic-1.5.8.ebuild
new file mode 100644
index 000000000000..80e8098f34d2
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.5.8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/pykwalify-1.6.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.17.0[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/flexmock[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-systemd_service_bin_path.patch
+ "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Unlike the other two test files in integration/commands, which use the
+ # relevant modules' respective APIs, test_borgmatic.py tries to call the
+ # 'borgmatic' executable - which by the time we execute src_test will
+ # not have been created yet. distutils_install_for_testing would likely
+ # take care of this - but between the aforementioned behaviour inconsistency
+ # and the fact the only test run from this file as of version 1.5.1 is the
+ # parsing of contents of 'borgmatic --version', just skip it for now.
+ rm -f "${S}"/tests/integration/commands/test_borgmatic.py
+}
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}